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Chapter 1:

The APL Environment

Introduction
The Dyalog Development Environment includes a Session Manager, an Editor, and a
Tracer all of which operate in windows on the screen. The session window is created
when you start APL and is present until you terminate your APL session. In addition
there may be a number of edit and/or trace Windows, which are created and
destroyed dynamically as required. All APL windows are under the control of
Windows and may be selected, moved, resized, maximised and minimised using the
standard facilities that Windows provides.

APL Keyboards
The Classic and Unicode Editions of Dyalog APL for Windows use different
techniques for mapping keystrokes to APL characters and to special command
shortcuts.

The Classic Edition uses a proprietary technique for these mappings.

By default, the Unicode Edition uses Microsoft's IME (Input Method Editor)
technology. Many other applications use the same technology, which means that the
Dyalog Unicode IME may be used not only with Dyalog APL for Windows Unicode
Edition, but also with word processing applications, spreadsheets, terminal emulators
etc. Therefore with the Dyalog Unicode IME installed, and with a suitable font
selected, APL characters can be entered and viewed in many other applications.

As an alternative to the Dyalog Unicode IME, whose installation requires
Administrator privileges, the key mapping for the Unicode Edition may be specified
in the Windows registry. See Unicode Edition and the Registry Keyboard on page 3.

In both Classic and Unicode Editions APL characters are generated when the user
presses certain combinations of meta keys in conjunction with the normal character
keys. Meta keys include Shift, Ctrl and Alt.
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For both input techniques it is possible to alter the mapping of keystrokes to APL
characters, and to add support for new languages. It is also possible to alter the
keystrokes which define special command keyboard shortcuts. For further details, see
Unicode Edition Keyboard on page 9 or Classic Edition Keyboard on page 13

Unicode Edition and the Dyalog Unicode IME
The Dyalog Unicode IME is the default input mechanism for generating
APL characters for Unicode editions of Dyalog APL. The version of the
IME supplied with version 19.0 can be used with version 12.1 and later, provided
that they are patched to a version created on or after 1st April 2011.

The Dyalog Unicode IME defines the mapping of keystrokes to Unicode characters.
Only keystrokes which resolve to characters that either do not appear on the standard
keyboard or which differ from those that appear on the standard keyboard are
included in the selectable translate table. In effect the Dyalog Unicode IME can be
regarded as an overlay of the standard keyboard which contains just APL characters.

The Dyalog Unicode IME supplied with Version 19.0 includes support for Belgian,
Danish, Finnish, French, German, Italian, Spanish Swedish and British and American
English keyboards, based on the Dyalog hardware keyboard layout; these keyboard
layouts are described at https://dfns.dyalog.com/n_keyboards.htm. Note that for
Danish, British and American English keyboards the older layouts, based on the
Dyalog APL Ctrl Keyboard, are included in the UnicodeIME\aplkeys directory.

The default keyboard mapping for unsupported languages is American English.

The IME translate tables include mappings for the special command keystrokes used
by Dyalog APL.

These command keystroke mappings are ignored by applications unless the
application is explicitly named in the Dyalog Unicode IME configuration. It is
expected that only terminal emulators used for running UNIX-based versions of
Dyalog APL will use this feature.

In particular, Dyalog APL for Windows Unicode Edition does not use the mappings
in the translate tables; the mappings are defined under Options/Configure/Keyboard
Shortcuts (see Installation & Configuration Guide: Configuration Dialog: Keyboard
Shortcut Tab).

Note that the Dyalog Unicode IME replaces any previous IME, as well as the Dyalog
Ctrl and Dyalog AltGr keyboards.
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Unicode Edition and the Registry Keyboard
The Registry Keyboard provides an alternative mechanism for the Unicode Edition.
This feature maps keystrokes to APL characters using entries in the Windows
Registry. Dyalog supports the mechanism but does not provide the mappings which
must therefore be defined by the user.

Note that the Dyalog IME is used if it is available; the Registry Keyboard mechanism
is used only if the Dyalog IME is not installed.

The mappings are defined in the Registry sub-folder :

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Dyalog\
Dyalog APL/W-64 19.0 Unicode\KeyboardShortcuts\chars

Each entry consists of theUnicode code point of an APL character followed by the
keystroke to which it is mapped.

The keystroke is defined by 4 hexadecimal values which specify the key, the shift-
state, and 2 zeros. The key is represented by the Unicode code point of the symbol
engraved upon it, so (on a UK keyboard) the <1> key is hex 31 and the <A> key is
hex 41. The Shift-states values are the sum of 1 (Shift), 2 (Ctrl), 4 (Alt).

"0x230A"=hex:44,02,00,00
"0x235F"=hex:38,03,00,00

In the first entry, the APL character is Unicode code point 230A which is ⌊. The key
is <D> (hex 44) and the shift-state is Ctrl (hex 02).

In the second entry, the APL character is Unicode code point 235F which is ⍟. The
character is entered by pressing <*> ( hex 38) with Shift+Ctrl (hex 03).

Classic Edition
The mapping for each of the ⎕AV positions and its associated keystroke is defined by
a selectable translate table. ⎕AV includes all the APL symbols used by Dyalog APL
as well as all the (non-APL) characters which appear on a standard keyboard. This
mapping only works with Classic Edition.

The Classic Edition installation also includes the Dyalog Unicode IME (described
below) so that users may enter APL characters into other applications; the Dyalog
Unicode IME is however not used by the Classic Edition itself.

The Classic Edition includes support for Danish, Finnish, French, German, Italian,
Swedish, and both British and American English keyboards. The default keyboard
mapping for unsupported languages is American English.

Backtick Keyboard
In addition to the standard APL keyboards, the RIDE keyboard may be used natively.
See Backtick Keyboard on page 11.
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Session Manager
The Dyalog APL/W session is fully configurable. Not only can you change the
appearance of the menus, tool bars and status bars, but you can add new objects of
your choice and attach your own APL functions and expressions to them. Functions
and variables can be stored in the session namespace. This is independent of the
active workspace; so there is no conflict with workspace names, and your utilities
remain permanently accessible for the duration of the session. Finally, you may set
up different session configurations for different purposes which can be saved and
loaded as required.

The session window is defined by an object called ⎕SE. This is very similar to a
Form object, but has certain special properties. The menu bar, tool bar and status bars
on the session window are in fact MenuBar, ToolControl and StatusBar objects
owned by ⎕SE. All of the other components such as menu items and tool buttons are
also standard GUI objects. You may use ⎕WC to create new session objects and you
may use ⎕WS to change the properties of existing ones. ⎕WG and ⎕WN may also be
used with ⎕SE and its children.

Components of the session that perform actions (MenuItem and Button objects) do so
because their Event properties are defined to execute system operations or APL
expressions. System operations comprise a pre-defined set of actions that can be
performed by Dyalog APL/W. These are coded as keywords within square brackets.
For example, the system operation [WSClear] produces a clear ws, after first
displaying a dialog box for confirmation. You may customise your session by adding
or deleting objects and by attaching system operations or APL expressions to them.

Like any other object, ⎕SE is a namespace that may contain functions and variables.
Furthermore, ⎕SE is independent of the active workspace and is unaffected by
)LOAD and )CLEAR. It is therefore sensible to store commonly used utilities,
particularly those utilities that are invoked by events on session objects, in ⎕SE itself,
rather than in each of your application workspaces.

The possibility of configuring your APL session so extensively leads to the
requirement to have different sessions for different purposes. To meet this need,
sessions are stored in special files with a .DSE (Dyalog Session) extension. The
default session (that is, the one loaded when you start APL) is specified by the
session_file parameter. You may customise this session and then save it over the
default one or in a separate file. You can load a new session from file at any stage
without affecting your active workspace.
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Positioning the Cursor
The cursor may be positioned within the current APL window by moving the mouse
pointer to the desired location and then clicking the Left Button. The APL cursor will
then move to the character under the pointer.

Selection
Dragging the mouse selects the text from the point where the mouse button is
depressed to the point where the button is released. When you select multiple lines,
the use of the left mouse button always selects text from the start of the line. A
contiguous block of text can be selected by dragging with the right mouse button.

Double-clicking the left mouse button to the left of a line selects the whole line,
including the end-of-line character.

Scrolling
Data can be scrolled in a window using the mouse in conjunction with the scrollbar.

Invoking the Editor
The Editor can be invoked by placing the mouse pointer over the name of an editable
object and double-clicking the left button on the mouse. If you double-click on the
empty Input Line it acts as "Naked Edit" and opens an edit window for the suspended
function (if any) on the APL stack. For further details, see Invoking the Editor on
page 113. See also "Installation and Configuration Guide: DoubleClickEdit".

The Current Object
If you position the input cursor over the name of an object in the session window,
that object becomes the current object. This name is stored in the CurObj property of
the Session object and may be used by an application or a utility program. This
means that you can click the mouse over a name and then select a menu item or click
a button that executes code that accesses the name.

The Session Pop-up Menu
Clicking the right mouse button brings up the Session pop-up menu. This is
described later in this chapter.
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Drag-and-Drop Editing
Drag-and-Drop editing is the easiest way to move or copy a selection a short distance
within an edit window or between edit windows.

To move text using drag-and-drop editing:

1. Select the text you want to move.
2. Point to the selected text and then press and hold down the left mouse button.

When the drag-and-drop pointer appears, drag the cursor to a new location.
3. Release the mouse button to drop the text into place.

To copy text using drag-and-drop editing:

1. Select the text you want to move.
2. Hold down the Ctrl key, point to the selected text and then press and hold

down the left mouse button. When the drag-and-drop pointer appears, drag the
cursor to a new location.

3. Release the mouse button to drop the text into place.

If you drag-and-drop text within the Session window, the text is copied and not
moved whether or not you use the Ctrl key.

Interrupts
To generate an interrupt, click on the Dyalog icon in the Windows System Tray; then
choose Weak Interrupt or Strong Interrupt. To close the menu, click Cancel.
Alternatively, to generate a weak interrupt, press Ctrl+Break, or select Interrupt from
the Action menu on the Session Window.



Chapter 1: The APL Environment 7

Session Gutter
The first column of the Session Window (the Session Gutter) is by default reserved
to display the following information:

l A small red circle. This indicator is used on every line that is modified in the
session, including old ones (for example, if you move up the session and
modify them, without pressing <ER>) . The indicators show which session
lines will be re-executed when you subsequently press <ER>.

l A left bracket [ to identify groups of default output. Note that other forms of
output are not identified in this way.

The Session Gutter may be enabled and disabled using the DYALOG_GUTTER_
ENABLE parameter. It is disabled by default in the TTY interface.
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Multi-line Session Input
The Session allows multi-line input. This feature is optional and is controlled by the
value of the Dyalog_LineEditor_Mode parameter which by default is 0 (off). To
enable the new behaviour, you must set the parameter to 1.

See Dyalog_LineEditor_Mode on page 1Installation & Configuration Guide:
Dyalog_LineEditor_Mode.

On Windows Multi-line input can be enabled and disabled via the checkbox on the
Session tab of the configuration parameter: see Installation & Configuration Guide:
Congiguration Dialog, Session Tab.

When Multi-line Input is Enabled:
l The session considers all related lines to be a group.
l Grouped lines are syntax coloured as a whole.
l If a change is made to one or more lines in a group then the whole group is
marked to be re-executed when ER is pressed.

l Lines can be inserted into a group with the IL keystroke.
l The current line can be cleared with the EL keystroke. (It is not possible to
UNDO a delete line in the session).

l if the interpreter detects an un-terminated control structure or dfn on a single
line of input it:
o enters a new multi-line mode which accumulates lines until the control

structure or dfn is terminated.
o executes a completed block of lines as if it were within a niladic defined

function.

Multi-line input can be terminated by correctly terminating the input. For example, if
you started a block of multi-line input with a { character, then a matching and
similarly nested } character terminates it. Similarly, if you started a block of multi-
line input with :If then a matching and similarly nested :EndIf terminates it.
Issuing a weak interrupt aborts the multi-line input and all changes are lost.

../../../../../Content/UserGuide/Installation and Configuration/Configuration Parameters/Dyalog_LineEditor_Mode.htm#Dyalog_LineEditor_Mode
../../../../../Content/UserGuide/Installation and Configuration/Configuration Parameters/Dyalog_LineEditor_Mode.htm#Dyalog_LineEditor_Mode
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Unicode Edition Keyboard
Introduction
Unicode Edition supports the use of standard Windows keyboards that have the
additional capability to generate APL characters when the user presses Ctrl, Alt,
AltGr (or some other combination of meta keys) in combination with the normal
character keys.

Dyalog is supplied with the Dyalog Unicode IME keyboard for a range of different
languages as listed below. The intention is that only APL characters and characters
that appear in locations different from the underlying keyboard are defined; any other
keystroke is passed through as is.

Installation
During the Installation of Dyalog Unicode Edition, setup installs the Dyalog Unicode
IME (IME). For any given Input Language the IME consists of an additional service
for that Input Language, and a translate table which maps keystrokes for the
appropriate keyboard to Unicode code points for APL characters

An IME service is installed for every Input Language that the user who installs
Dyalog has defined, as well as every Input Language for which Dyalog has support.

The keyboard mappings are defined for the following national languages: Belgian,
Danish, Finnish, French, German, Italian, Spanish, Swedish, and British and
American English.

These mappings are described at https://dfns.dyalog.com/n_keyboards.htm.

For any other Input Language the American English translate table is selected. Note
that some Input Languages are defined to be substitutes for other Input Languages;
for example Australian English Input is a substitute for American English Input,
Austrian German Input a substitute for German German Input. In these cases the IME
will install the appropriate translate table. It is also possible to create support for new
languages or to modify the existing support. See the IME User Guide for further
details.
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Configuring the Dyalog IME
The Dyalog Unicode IME is added as an additional service to all keyboards defined
to the user and the administrator at the time that the IME was installed.

For each IME the underlying keyboard layout file will be the same as that defined for
the base keyboard. The layout file is a DLL created by Microsoft.

The language specified in the description of the IME is the name of the IME translate
table that has been associated with the IME for the specific keyboard. In the case of
languages not supported by the IME the keyboard will default to en-US.

IME Properties
To change the properties of the IME go to Options/Configure/Unicode Input tab and
select Configure Layout:
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Input translate table:
The translate table defines the mapping between APL characters and the keystrokes
that generate those APL characters. It is possible to alter the mapping or to create
support for new keyboards by altering the translate table, or by selecting a different
translate table. See the IME User Guide for more details.

Backtick Keyboard
The Backtick keyboard provided by the RIDE may be used natively. By default it is
disabled. To enable it, check the box labelled Enable Backtick Keyboard introducer.
You may replace the backtick character (`) with an alternative character to act as the
introducer for APL glyphs, but take care to choose a character that is otherwise
unused.

For information on using this keyboard interface, see RIDE User Guide.
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Overstrikes:
In the original implementations of APL, many of the special symbols could only be
generated by overstriking one character on top of another as is reflected in the
appearance of the glyphs. For example, the symbol for Grade Up (⍋) is actually the
symbol for delta (∆) superimposed on the symbol for vertical bar (|)

In Dyalog, such symbols can be generated either by a single keystroke, or (in
Replace mode) by overtyping one symbol with another. For example ⍋ may be
generated using Shift+Ctrl+4, or by switching to Replace mode and typing the three
keystrokes Ctrl+h, Left-Cursor, Ctrl+m.

Using the Dyalog Unicode IME the character can also be entered by pressing
Ctrl+Bksp, Ctrl+m, Ctrl+h. Note that Ctrl+Bksp is the default Overstrike Introducer
Key (key code OS).

Use Overstrike popup:
With this option selected, when the character following the Overstrike Introducer
Key is pressed, a popup box displays all the overstrikes which contain the last
character typed: in the example below Ctrl+Bksp has been followed by Ctrl+h:

Note the fine (red) line under the ∆. This indicates that an overstrike creation
operation is in progress.

The input of the symbol ⍋ can be completed by pressing Ctrl+m, or by moving the
selection up and down the pop-up list using Cursor-Up or Cursor-Down. 

Overstrikes do not require the OS introducer key:
With this option selected, the IME identifies characters which are part of a valid
overstrike, and when such a character is entered into the session, begins an overstrike
creation operation.
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Classic Edition Keyboard
The standard Classic Edition keyboard tables are files supplied in the aplkeys sub-
directory named cc.din where cc is the standard 2-character country code, for
example, uk.din.

Note that the standard tables do not support the entry of APL underscored characters
⍙ⒶⒷⒸⒹⒺⒻⒼⒽⒾⒿⓀⓁⓂⓃⓄⓅⓆⓇⓈⓉⓊⓋⓌⓍⓎⓏ.

The standard table supports two modes of use; traditional (mode 0) and unified
(mode 1). The keyboard starts in mode 1 and may be switched between modes by
clicking the Uni/Apl field in the status bar or by keying * on the Numeric-Keypad.

The Classic Edition keyboard layout is close to that of the Unicode Edition, but does
not include certain symbols which are only provided in the Unicode Edition.

Keyboard Shortcuts
The terms keyboard shortcut (Unicode Edition) and command (Classic Edition) are
used herein to describe a keystroke that generates an action, rather than one that
produces a symbol.

Unicode Edition
Unicode Edition provides a number of shortcut keys that may be used to perform
actions. For compatibility with Classic Edition and with previous versions of Dyalog,
these are identified by 2-character codes; for example the action to start the Tracer is
identified by the code <TC>, and mapped to user-configurable keystrokes.

In the Unicode Edition, Keyboard Shortcuts are defined using
Options/Configure/Keyboard Shortcuts and stored in the Windows Registry.  Note
that the Unicode IME translate tables have definitions for the Keyboard Shortcuts
too; these are ignored by the interpreter, and are intended for use with terminal
emulators being used in conjunction with non-GUI versions of Dyalog.

To the right of the last symbol in the Language Bar is the Keyboard Shortcut icon

. If you hover the mouse over this icon, a pop-up tip is displayed to remind you
of your keyboard shortcuts as illustrated below.
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Classic Edition
Commands fall into four categories, namely cursor movement, selection, editing
directives and special operations, and are summarised in the following tables. The
input codes in the first column of the tables are the codes by which the commands
are identified in the Input Translate Table.

Table 1: Cursor Movement Commands
Input
Code Keystroke Description

LS Ctrl+PgUp Scrolls left by a page

RS Ctrl+PgDn Scrolls right by a page

US PgUp Scrolls up by a page

DS PgDn Scrolls down by a page

LC Left Arrow Moves the cursor one character position to the left

RC Right Arrow Moves the cursor one character position to the right

DC Down Arrow Moves the cursor to the current character position
on the line below the current line

UC Up Arrow Moves the cursor to the current character position
on the line above the current line

UL Ctrl+Home Move the cursor to the top-left position in the
window

DL Ctrl+End Moves the cursor to the bottom-right position in the
window

RL End Moves the cursor to the end of the current line

LL Home Moves the cursor to the beginning of the current line

LW Ctrl+Left Arrow Moves the cursor to the beginning of the word to the
left of the cursor

RW Ctrl+Right
Arrow

Moves the cursor to the end of the word to the right
of the cursor

TB Ctrl+Tab Switches to the next session/edit/trace window

BT Ctrl+Shift+Tab Switches to the previous session/edit/trace window
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Table 2: Selection Commands
Input
Code Keystroke Description

Lc Shift+Left Arrow Extends the selection one character position to the
left

Rc Shift+Right Arrow Extends the selection one character position to the
right

Lw Ctrl+Shift+Left
Arrow

Extends the selection to the beginning of the word
to the left of the cursor

Rw Ctrl+Shift+Right
Arrow

Extends the selection to the end of the word to the
right of the cursor

Uc Shift+Up Arrow Extends the selection to the current character
position on the line above the current line

Dc Shift+Down
Arrow

Extends the selection to the current character
position on the line below the current line

Ll Shift+Home Extends the selection to the beginning of the
current line

Rl Shift+End Extends the selection to the end of the current line

Ul Ctrl+Shift+Home Extends the selection to the beginning of the first
line in the window

Dl Ctrl+Shift+End Extends the selection to the end of the last line in
the window

Us Shift+PgUp Extends the selection up by a page

Ds Shift+PgDn Extends the selection down by a page
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Table 3: Editing Directives
Input
Code Keystroke Description

DI Delete Deletes the selection

DK Ctrl+Delete Deletes the current line in an Edit window. Deletes
selected lines in the Session Log

CT Shift+Delete Removes the selection and copies it to the
clipboard

CP Ctrl+Insert Copies the selection into the clipboard

FD Ctrl+Shift+Enter Reapplies the most recent undo operation

BK Ctrl+Shift+Bksp Performs an undo operation

PT Shift+Insert Copies the contents of the clipboard into a window
at the location selected

OP Ctrl+Shift+Insert Inserts a blank line immediately after the current
one (editor only)

HT Tab Indents text

TH Shift+Tab Removes indentation

RD Keypad-slash Reformats a function (editor only)

TL Ctrl+Alt+L Toggles localisation of the current name

GL Ctrl+Alt+G Go to [line]

AO Ctrl+Alt+, Add Comments

DO Ctrl+Alt+. Delete Comments

AC Align Comments
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Table 4: Special Operations
Input
Code Keystroke Description

IN Insert Insert on/off

LN Keypad-minus Line numbers on/off

ER Enter Execute

ED Shift+Enter Edit

TC Ctrl+Enter Trace

EP Esc Exit

QT Shift+Esc Quit
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The Session Colour Scheme
Within the Development Environment, different colours are used to identify different
types of information. These colours are normally defined by registry entries and may
be changed using the Colour Configuration dialog box as described later in this
chapter.

In the Classic Edition, colours may alternatively be defined in the Output Translate
Table (normally WIN.DOT). This table recognises up to 256 foreground and 256
background colours which are referenced by colour indices 0-255. These colour
indices are mapped to physical colours in terms of their Red, Green and Blue
intensities (also 0-255). Foreground and background colours are specified
independently as Cnnn or Bnnn. For example, the following entry in the Output
Translate Table defines colour 250 to be red on magenta.

C250: 255 0 0   + Red foreground
B250: 255 0 255 + Magenta background

The first table below shows the colours used for different session components. The
second table shows how different colours are used to identify different types of data
in edit windows.

Table 5: Default Colour Scheme - Session
Colour Used for Default

249 Input and marked lines Red on White

250 Session log Black on White

252 Tracer : Suspended Function Yellow on Black

253 Tracer : Pendent Function Yellow on Dark Grey

245 Tracer : Current Line White on Red
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Table 6: Default Colour Scheme Edit windows
Colour Array Type Editable Default

236 Simple character matrix Yes Green on Black

239 Simple numeric No White on Dk Grey

241 Simple mixed No Cyan on Dk Grey

242 Character vector of vectors Yes Cyan on Black

243 Nested array No Cyan on Dk Grey

245 ⎕OR object No White on Red

248 Function or Operator No White on Dk Cyan

254 Function or Operator Yes White on Blue

Syntax Colouring in the Session
As an adjunct to the overall Session Colour Scheme, you may choose to apply a
syntax colouring scheme to the current Session Input line(s). You may also extend
syntax colouring to previously entered input lines, although this only applies to input
lines in the current session; syntax colouring information is not remembered in the
Session Log.

Syntax colouring may be used to highlight the context of names and other elements
when the line was entered. For example, you can identify global names and local
names by allocating them different colours.

See Installation & Configuration Guide: Colour Selection Dialog for further details.
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The Session Window
The primary purpose of the session window is to provide a scrolling area within
which you may enter APL expressions and view results. This area is described as the
session log. Normally, the session window will have a menu bar at the top with a tool
bar below it. At the bottom of the session window is a status bar. However, these
components of the session may be extensively customised and, although this chapter
describes a typical session layout, your own session may look distinctly different. A
typical Session is illustrated below.

A typical Session window
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Window Management
When you start APL, the session is loaded from the file specified by the session_file
parameter. The position and size of the session window are defined by the Posn and
Size properties of the Session object ⎕SE, which will be as they were when the
session file was last saved.1

The name of the active workspace is shown in the title bar of the window, and
changes if you rename the workspace or )LOAD another.

You can move, resize, minimise or maximise the Session Window using the standard
Windows facilities.

In addition to the Session Window itself, there are various subsidiary windows which
are described later in the Chapter. In general, these subsidiary windows may be
docked inside the Session window, or may be stand-alone floating windows. You
may dock and undock these windows as required. The standard Session layout
illustrated above, contains docked Editor, Tracer and SIStack windows.

Note that the session window is only displayed when it is required, that is, when
APL requests input from or output to the session. This means that end-user
applications that do not interact with the user through the session will not have an
APL session window.

1In a Windows shortcut to an application, the Run: state may be one of "Normal window",
"Minimised" and "Maximised". There are other states which can be set when a process is spawned. If
the Run: state is Normal or Default, Dyalog will use the settings in the current session file to
determine the state and size of the session on startup; for all other states (including Maximised and
Minimised) these states will be used, superceding the settings in the current session file.
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Docking
Nearly all of the windows used in the Dyalog IDE may be docked in the Session
window or be stand-alone floating windows. When windows are docked in the
Session, the Session window is split into resizable panes, separated by splitters. The
following example, using the Status window, illustrates the principles involved. (The
use of the Status window is described later in this Chapter.)

To start with, the Status window is hidden. You may display it by selecting the Status
menu item from the Tools menu. It initially appears as a floating (undocked) window
as shown below.
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If you press the left mouse button down over the Status window title bar, and drag it,
you will find that when the mouse pointer is close to an edge of the Session window,
the drag rectangle indicates a docking zone as shown below. This indicates the space
that the window will occupy if you now release the mouse button to dock it.
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The next picture shows the result of the docking operation. The Session window is
now split into 2 panes, with the Status window in the upper pane and the Session log
window in the lower pane. You can resize the panes by dragging with the mouse.

You will notice that a docked window has a title bar (in this case, the caption is
Status) and 3 buttons which are used to Minimise, Maximise and Close the docked
window.
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The next picture shows the result of minimising the Status window pane. All that
remains of it is its title bar. The Minimise button has changed to a Restore button,
which is used to restore the pane to its original size.
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You can pick up a docked window and then re-dock it along a different edge of the
Session as illustrated below.

Docking the Status window along the left edge of the Session causes the Session
window to be split into two vertical panes. Notice how the title bar is now drawn
vertically.
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If you click the right mouse button over any window, its context menu is displayed.
If the window is dockable, the context menu contains the following options:

Undock Undocks the docked window. The window is displayed at
whatever position and size it occupied prior to being docked

Hide
Caption Hides the title bar of the docked window

Dockable
Specifies whether the window is currently dockable or is locked in
its current state. You can use this to prevent the window from
being docked or undocked accidentally

The last picture shows the effect of using Hide Caption to remove the title bar. In this
state, you can resize the pane with the mouse, but the Minimise, Maximise and Close
buttons are not available. However, you can restore the object's title bar using its
context menu.
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Language Bar
The Language Bar is an optional window which is initially docked to the Session
Window, to make it easy to pick APL symbols without using the keyboard.

If you hover the mouse pointer over a symbol in the Language Bar, a pop-up tip is
displayed to remind you of its usage. If you click on a symbol in the Language Bar,
that symbol is inserted at the cursor in the current line in the Session.
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Popup Menu
If you click the right mouse button in the Language Bar, the context menu displays
the following options:

Item Description

Insert
Space
Before

Inserts a blank space before the current symbol (or blank)

Delete Deletes the current symbol (or blank)

Help Displays the (F1) help topic for the current symbol.

Use the
Session
font

Displays the symbols using the current Session font (by default
the symbols are displayed using a small font)

Revert to
defaults

Removes all user customisation and reverts to the standard
Language Bar.
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Entering and Executing Expressions
Introduction
The session contains the input line and the session log. The input line is the last line
in the session, and is (normally) the line into which you type an expression to be
evaluated.

The session log is a history of previously entered expressions and the results they
produced.

If you are using a log file, the Session log is loaded into memory when APL is
started from the file specified by the log_file parameter. When you close your APL
session, the Session log is written back out to the log file, replacing its previous
contents.

In general you type an expression into the input line, then press Enter (ER) to run it.
After execution, the expression and any displayed results become part of the session
log.

You can move around in the session using the scrollbar, the cursor keys, and the
PgUp and PgDn keys. In addition, Ctrl+Home (UL) moves the cursor to the
beginning of the top-line in the Log and Ctrl+End (DL) moves the cursor to the end
of the last (that is, the current) line in the session log. Home (LL) and End (RL)
move the cursor to the beginning and end respectively of the line containing the
cursor.

Deleting Lines
You may delete one or more lines from the Session using the DK command
(Ctrl+Delete). This action removes the current line or the selected block of lines from
the Session window and from the Session log. The removal is permanent and you
will be prompted to confirm:
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Auto Complete
As you start to enter characters in an APL expression, the Auto Complete suggestions
pop-up window (AC for short) offers you a choice based upon the characters you
have already entered and the current context.

For example, if you enter a ⎕, AC displays a list of all the system functions and
variables. If you then enter the character r, the list shrinks to those system functions
and variables beginning with the letter r, namely ⎕refs, ⎕rl, ⎕rsi, and ⎕rtl.
Instead of entering the remaining characters, you may select the appropriate choice in
the AC list. This is done by pressing the right cursor key.

If you begin to enter a name, AC will display a list of namespaces, variables,
functions, operators that are defined in the current namespace. If you are editing a
function, AC will also include names that are localised in the function header.

If the current space is a GUI namespace, the list will also include Properties, Events
and Methods exposed by that object.

As an additional refinement, AC remembers a certain number of previous auto
complete operations, and uses this information to highlight the most recent choice
you made.

For example, suppose that you enter the two characters )c. AC offers you )clear
thru' )cs, and you choose )cs from the list. The next time you enter the two
characters )c, AC displays the same list of choices, but this time )cs is pre-selected.

You can disable or customise Auto Completion from the Auto Complete page in the
Configuration dialog box which is described later in this chapter.

Executing an Expression
To execute an expression, you type it into the input line, then press Enter (ER).
Alternatively, you can select Execute from the Action menu. Following execution, the
expression and any displayed results become part of the session log.

Instead of entering a new expression in the input line, you can move back through the
session log and re-execute a previous expression (or line of a result) by simply
pointing at it with the cursor and pressing Enter. Alternatively, you can select
Execute from the Action menu. You may alter the line before executing it. If you do
so, it will be displayed using colour 249 (Red on White), the same as that used for
the input line. When you press Enter the new line is copied to the input line prior to
being executed. The original line is restored and redisplayed in the normal session
log colour 250 (Black on White).
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An alternative way to retrieve a previously entered expression is to use
Ctrl+Shift+Bksp (BK) and Ctrl+Shift+Enter (FD). These commands cycle backwards
and forwards through the input history, successively copying previously entered
expressions over the current line. When you reach the expression you want, simply
press Enter to re-run it. These operations may also be performed from the Edit menu
in the session window.

Executing Several Expressions
You can execute several expressions, by changing more than one line in the session
log before pressing Enter. Each line that you change will be displayed using colour
249 (Red on White). When you press Enter, these marked lines are copied down and
executed in the order they appear in the log.

Note that you don't actually have to change a line to mark it for re-execution; you
can mark it by overtyping a character with the same character, or by deleting a
leading space for instance.

It is also possible to execute a contiguous block of lines. To do this, you must first
select the lines (by dragging the mouse or using the keyboard) and then copy them
into the clipboard using Shift+Delete (CT) or Ctrl+Insert (CP). You then paste them
back into the session using Shift+Insert (PT). Lines pasted into the session are always
marked (Red on White) and will therefore be executed when you press Enter. To
execute lines from an edit window, you use a similar procedure. First select the lines
you want to execute, then cut or copy the selection to the clipboard. Then move to
the session window and paste them in, then press Enter to execute them.

Session Print Width (PW)
Throughout its history, APL has used a system variable ⎕PW to specify the width of
the user's terminal or screen. Session output that is longer than ⎕PW is automatically
wrapped and split into multiple lines on the display. This feature of APL was
designed in the days of hard-copy terminals and has become less relevant in modern
Windows environments.

Dyalog continues to support the traditional use of ⎕PW, but also provides an
alternative option to have the system wrap Session output according to the width of
the Session Window. This behaviour may be selected by checking the Auto PW
checkbox in the Session tab of the Configuration dialog box.



Chapter 1: The APL Environment 34

Using Find/Replace in the Session
The search and replace facilities work not just in the Editor as you would expect, but
also in the Session. For example, if you have just entered a series of expressions
involving a variable called SALES and you want to perform the same calculations
using NEWSALES, the following commands will achieve it:

Enter SALES in the Find box, and NEWSALES in the Replace box. Now click the
Replace All button. You will see all occurrences of SALES change to NEWSALES.
Furthermore, each changed line in the session becomes marked (Red on White). Now
click on the session and press Enter (or select Execute from the Action menu).

Once displayed, the Find or Find/Replace dialog box remains on the screen until it is
either closed or replaced by the other. This is particularly convenient if the same
operations are to be performed over and over again, and/or in several windows. Find
and Find/Replace operations are effective in the window that previously had the
focus.
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Value Tips
If you hover the mouse pointer over a name in the Session or Debugger window,
APL will display a pop-up window containing the value of the symbol under the
mouse pointer.

For example, in the following picture the mouse pointer was moved over the name of
the variable HW in the Session window.

The next picture illustrates the Value Tip displayed when the mouse is hovered over
the name of the variable MAT.
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Similarly, if you hover the mouse pointer over the name of a function, the system
displays the body of the function as a pop-up, as illustrated below.
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Value Tips for External Functions
Value Tips can also be used to investigate the syntax of external functions. If you
hover over the name of an external function, the Value Tip displays its Function
Signature.

For example, in the example below, the mouse is hovered over the external function
dt.AddMonths and shows that it requires a single integer as its argument.

Should the external function provide more than one signature, they are all shown in
the Value Tip as illustrated below. Here the function ToString has four different
overloads.
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Configuring Value Tips
You may enable/disable Value Tips and select other options from the General tab of
the Configuration dialog box as shown below.

You may experiment by changing the value of the delay before which Value Tips are
displayed, until you find a comfortable setting.

Note that the colour scheme used to display the Value Tip for a function need not
necessarily be the same colour scheme as you use for the function editor.



Chapter 1: The APL Environment 39

Array Editor
The Array Editor1 allows you to edit arbitrary arrays. It is invoked by either:

l Clicking the icon in the Session toolbar when the mouse pointer is over
the name of a suitable variable.

l Calling the user command ]array.edit, specifying the name of a suitable
variable as its argument.

l Calling it directly via ⎕NA

The Array Editor draws data using a format that is similar to the output of the
DISPLAY function. For example:

1Array Editor Version 1 Release 1 © Copyright davidliebtag.com 2012, 2015
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Documentation
Full documentation for the Array Editor, including a list of the keystrokes it uses, is
available from the Help menu in the Array Editor's window.

Supported Arrays
The Array Editor supports arrays that consist solely of characters and/or numbers.
You may not use it to edit an array that contains an object reference or a ⎕OR.

Reject unsupported data

The way that the Arrays Editor reacts to unsupported arrays is determined by the
value of the Reject unsupported data option which is accessed by the
Options/Reject unsupported data menu item on the Array Editor menubar.

If this is set to true (the default), and you try to edit an array containing an object
reference, the Array Editor will refuse to start and the system will generate an error
message.

⎕SE.NumEd.numed: Unexpected error in array editor:
DOMAIN ERROR Argument contained data that is
neither simple or nested.

If this option is cleared, the Array editor will start but you will not be able to do
anything. It is therefore advisable that you leave this option set.

Notes
l The Array Editor is supplied only with Unicode Editions of Dyalog APL/W.
Please visit www.davidliebtag.com for details about availability and support
for Classic Editions of Dyalog APL/W.

l Namespaces are not supported.
l Internal representations returned by ⎕OR are not supported.
l Only one instance of the Array Editor may be executed at a time.
l All calls to interpreter primitives use a value of 3 for ⎕ML.
l Negative numbers must be represented using high minus signs. For example,
¯3 not -3.
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Implementation
The Array Editor is implemented by a DLL named dlaedit.dll (32-bit) or
dlaedit64.dll (64-bit).

The DLL exports two functions: DyalogEditArray and
DyalogEditArrayTitle. The latter is used when you click the icon in the
Session toolbar (via the APL function ⎕SE.NumEd.numed) and by the user
command ]array.edit

Calling the Array Editor Directly
If you wish to use the Array Editor directly, you may do so as follows using ⎕NA1.

For both DyalogEditArray and DyalogEditArrayTitle the first argument
is the array to be edited, while the second argument is a place holder and should
always be 0

For DyalogEditArrayTitle the 3rd argument is a character vector whose
contents are displayed in the caption of the array editor window.

The result is the newly altered array.

Examples
⎕NA'dlaedit.dll|DyalogEditArray <pp >pp' ⍝ 32-bit
⎕NA'dlaedit.dll|DyalogEditArrayTitle <pp >pp <0C2[]' ⍝ 32-bit

⎕NA'dlaedit64.dll|DyalogEditArray <pp >pp' ⍝ 64-bit
⎕NA'dlaedit64.dll|DyalogEditArrayTitle <pp >pp <0C2[]'⍝ 64-bit

New←DyalogEditArray Old 0
New←DyalogEditArrayTitle Old 0 Name

1Note that these are not standard ⎕NA calls, but rather use an extension to ⎕NA, called Direct
Workspace Access. Dyalog does not intend to make this feature generally available at present: if you
are interested in this feature please contact sales@dyalog.com.
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The Session GUI Hierarchy
As distributed, the Session object ⎕SE contains two CoolBar objects. The first,
named ⎕SE.cbtop runs along the top of the Session window and contains the
toolbars. The second, named ⎕SE.cbbot, runs along the bottom of the Session
windows and contains the statusbars.

The menubar is implemented by a MenuBar object named ⎕SE.mb.

The toolbars in ⎕SE.cbtop are implemented by four CoolBand objects, bandtb1,
bandtb2, bandtb3 and bandtb4 each containing a ToolControl named tb.

The statusbars in ⎕SE.cbbot are implemented by two CoolBand objects,
bandtb1 and bandtb2, each containing a StatusBar named sb.
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The Session MenuBar
The Session MenuBar (⎕SE.mb) contains a set of menus as follows. Note that,
unless specified, the screen-shots are taken using Unicode Edition and the keyboard
short-cuts will be different in Classic Edition.

The File Menu
The File menu (⎕SE.mb.file) provides a means to execute those APL System
Commands that are concerned with the active and saved workspaces. The contents of
a typical File menu and the operations they perform are illustrated below.
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Table 7: File Menu Operations
Item Action Description

New [WSClear] Prompts for confirmation, then clears
the workspace

Open [WSLoad] Prompts for a workspace file name,
then loads it

Copy [WSCopy] Prompts for a workspace file name,
then copies it

Save [WSSave] Saves the active workspace

Save As [WSSaveas]
Prompts for a workspace file name,
then saves it

Export [Makeexe]

Creates a bound executable, an OLE
Server, an ActiveX Control, or a
.NET Assembly. See Installation &
Configuration Guide: Creating
Executables and OLE Servers.

Export to
Memory

[MakeMemory
Assembly]

Creates an in-memory .NET
Assembly

Close
AppDomain [CloseAppDomain] Closes .NET App Domain

Drop [WSDrop]
Prompts for a workspace file name,
then erases it

Edit Text
File [EditTextFile]

Displays the Open Source File dialog
to select a file to exit.

Print [PrintFnsInNS]
Prints functions and operators in
current namespace

Print Setup [PrintSetup] Invokes the print set-up dialog box

Continue [Continue]
Saves the active workspace in
CONTINUE.DWS and exits APL

Exit [Off] Exits APL
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Edit Text File
The Edit Text File menu item allows you to edit a Dyalog script file (.dyalog) or an
arbitrary text file. The system prompts you to choose the file as shown below:

The file is then displayed in the Editor, allowing you to change it and save it. See
Editing Scripts and Text Files on page 151.
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The Edit Menu
The Edit menu (⎕SE.mb.edit) provides a means to recall previously entered input
lines for re-execution and for copying text to and from the clipboard.

Unicode Edition

Classic Edition
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Table 8: Edit menu operations
Item Action Description

Back [Undo]
Displays the previous input line. Repeated
use of this command cycles back through
the input history.

Forward [Redo]
Displays the next input line. Repeated use of
this command cycles forward through the
input history.

Cut [Delete] Cuts the selected text to the clipboard

Copy [Copy] Copies the selection to the clipboard

Paste [Paste]

Pastes the text contents of the clipboard into
the session log at the current location. The
new lines are marked and may be executed
by pressing Enter.

Paste
Unicode [PasteUnicode]

Same as Paste, but gets the Unicode text
from the clipboard and converts to ⎕AV.
Classic Edition only

Paste
Non-
Unicode

[PasteAnsi]
Same as Paste, but gets the ANSI text from
the clipboard and converts to ⎕AV. Classic
Edition only

Find [Find] Displays the Find dialog box

Replace [Replace] Displays the Find/Replace dialog box
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The View Menu
The View menu (⎕SE.mb.view) toggles the visibility of the Session Toolbar,
StatusBar, and Language Bar.

Table 9: View menu operations
Item Action Description

Toolbar Shows/Hides Session toolbars

Statusbar Shows/Hides Session statusbars

LanguageBar Shows/Hides Language Bar

The Window Menu
This contains a single action (⎕SE.mb.windows) which is to close all of the Edit
and Trace windows and the Status window.

Table 10: Window menu operations
Item Action Description

Close all Windows [CloseAll] Closes all Edit and Trace windows

Note that [CloseAll] removes all Trace windows but does not reset the state
indicator.

In addition, the Window menu will contain options to switch the focus to any
subsidiary windows that are docked in the Session as illustrated above.
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The Session Menu
The Session menu (⎕SE.mb.session) provides access to the system operations
that allow you to load a session (⎕SE) from a session file and to save your current
session (⎕SE) to a session file. If you use these facilities rarely, you may wish to
move them to (say) the Options menu or even dispense with them entirely.

Table 11: Session menu operations
Item Action Description

Open [SELoad]

Prompts for a session file name, then loads the
session from it, replacing the current one. Sets the
File property of ⎕SE to the name of the file from
which the session was loaded.

Save [SESave]
Saves the current session (as defined by ⎕SE) to the
session file specified by the File property of ⎕SE

Save
As [SESaveAs]

Prompts for a session file name, then saves the
current session (as defined by ⎕SE) in it. Resets the
File property of ⎕SE.
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The Log Menu
The Log menu (⎕SE.mb.log) provides access to the system operations that
manipulate Session log files.

Table 12: Log menu operations
Item Action Description

Clear [NewLog]
Prompts for confirmation, then empties the current
Session log

Open [OpenLog]
Prompts for a Session log file, then loads it into
memory, replacing the current Session log

Save [SaveLog]
Saves the current Session log in the current log file,
replacing its previous contents

Save
As [SaveLogAs]

Prompts for a file name, then saves the current
Session log in it

Print [PrintLog] Prints the contents of the Session log

The Action Menu
The Action menu (⎕SE.mb.action) may be used to perform a variety of
operations on the current object or the current line. The current object is the object
whose name contains the cursor. The current line is that line that contains the cursor.
The Edit, Copy Object, Paste Object and Print Object items operate on the current
object. For example, if the name SALES appears in the session and the cursor is
placed somewhere within it, SALES is the current object and will be copied to the
clipboard by selecting Copy object or opened up for editing by selecting Edit.
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Table 13: Action menu operations
Item Action Description

Edit [Edit] Edit the current object

Trace [Trace]
Executes the current line under the control of the
Tracer

Execute [Execute] Executes the current line

Copy
Object [ObjCopy]

Copies the contents of the current object to the
clipboard

Paste
Object [ObjPaste]

Pastes the contents of the clipboard into the
current object, replacing its previous value

Print
Object [ObjPrint]

Prints the current object. Note that if the object
is being edited, the version of the object
displayed in the edit window is printed.

Clear
Stops [ClearTSM]

Clears all ⎕STOP, ⎕MONITOR and ⎕TRACE
settings

Interrupt [Interrupt] Generates a weak interrupt

Reset [Reset] Performs )RESET
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The Options Menu
The Options menu (⎕SE.mb.options) provides configuration options.

Table 14: Options menu operations
Item Action Description

Expose
GUI
Properties

[ExposeGUI]
Exposes the names of
properties, methods and
events in GUI objects

Expose
Root
Properties

[ExposeRoot]
Exposes the names of the
properties, methods and
events of the Root object

Expose
Session
Properties

[ExposeSession]
Exposes the names of the
properties, methods and
events of  ⎕SE

Line
Numbers [LineNumbers]

Toggle the display of
line numbers in edit and
trace windows on/off

Disable
traps in
session

[DisableTrapsAtSuspension]

Disables the error
trapping mechanism used
by :Trap and ⎕TRAP.
This can be useful in
debugging applications.

Configure [Configure]
Displays the
Configuration dialog box

Colours [ChooseColors]
Displays the Colours
Selection dialog box
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The values associated with the Expose GUI, Expose Root and Expose Session options
reflect the values of these settings in your current workspace and are saved in it.
When you change these values through the Options menu, you are changing them in
the current workspace only.

The default values of these items are defined by the parameters default_wx,
PropertyExposeRoot and PropertyExposeSE which may be set using the Object
Syntax tab of the Configuration dialog.

The Tools Menu
The Tools menu (⎕SE.mb.tools) provides access to various session tools and
dialog boxes.

Table 15: Tools Menu Operations
Item Action Description

Explorer [Explorer] Displays the Workspace Explorer tool

Search [WSSearch] Displays the Workspace Search tool

Status [Status] Displays or hides the Status window

AutoStatus [AutoStatus]
Toggle; if checked, causes the Status
window to be displayed when a new
message is generated for it

Event
Viewer [EventViewer] Displays or hides the Event Viewer

Properties [ObjProps]
Displays a property sheet for the current
object



Chapter 1: The APL Environment 54

The Threads Menu
The Threads menu (⎕SE.mb.threads) provides access to various session tools
and dialog boxes.

Table 16: Threads Menu Operations
Item Action Description

Show
Threads [Threads] Displays the Threads Tool

Show Stack [Stack] Displays the SI Stack window

Show Token
Pool [TokenPool]

Displays the Token Pool
window

Auto Refresh [ThreadsAutoRefresh]
Refreshes the Threads Tool on
every thread switch

Pause on
Error [ThreadsPauseOnError] Pauses all threads on error

Pause all
Threads [ThreadsPauseAll] Pauses all threads

Resume all
Threads [ThreadsResumeAll] Resumes all threads

Restart all
Threads [ThreadsRestartAll] Restarts all threads
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The Help Menu
The Help menu (⎕SE.mb.help) provides access to the help system which is
packaged as a single Microsoft HTML Help compiled help file named
help\dyalog.chm.
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Table 17: Help menu operations
Label Action Description

Getting Started [GettingStarted]
Opens your web browser on the
getting-started page on the
Dyalog web site

Dyalog Help [WelcomeHelp]
Opens help\dyalog.chm,
starting at the Welcome page

Language
Elements [LangHelp]

Opens help\dyalog.chm,
starting at the first topic in the
Language Reference section

GUI Overview [GuiHelp]
Opens help\dyalog.chm,
starting at the first topic in the
Object Reference section

Documentation
Centre [DocCenter]

Opens your web browser on
help\index.html which
displays an index to the on-line
PDF documentation and selected
internet links

Dyalog Web
Site [DyalogWeb]

Opens your web browser on the
Dyalog home page

Email Dyalog [DyalogEmail]
Opens your email client and
creates a new message to Dyalog
Support

Latest
Enhancements [RelNotes]

Opens help\dyalog.chm,
starting at the first topic in the
Version 19.0 Release Notes
section. Previous Release Notes
are also included for your
convenience.

Read Me [ReadMe]

Opens help\dyalog_
readme.htm in your default web
browser. Note that setup_
readme.htm is also included in this
directory

Third Party
Licences [LicenceHelp]

Opens help\dyalog.chm,
starting at the first topic in the
Licences for third-party
components

About [About] Displays an About dialog box
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Session Pop-Up Menu
The Session popup menu (⎕SE.popup) is displayed by clicking the right mouse
button anywhere in the Session or Editor window.
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If the mouse pointer is over a visible object name, the popup menu allows you to
edit, print, delete it or view its properties. Note that the name of the pop-up menu is
specified by the Popup property of ⎕SE.

Table 18: Session popup menu operations
Item Action Description

Edit [Edit]
Edits the current
object

Chart Wizard ⎕SE.Dyalog.Chart.
DoChart

Opens Chart Wizard
on current object

Print [ObjPrint]

Prints the current
object. Note that if the
object is being edited,
the version of the
object displayed in the
edit window is
printed.

Delete [ObjDelete]
Erases the current
object

Properties [GUIHelp]
Displays the Object
Properties dialog box
for the current object

Help [Help]

Displays the help
topic associated with
the current object or
the APL symbol under
the cursor

Select All [selectall]
Selects all text (Editor
only)

Cut [Cut] Deletes selected text

Copy [Copy]
Copies the selection to
the clipboard
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Item Action Description

Paste [Paste]

Pastes the text
contents of the
clipboard into the
session log at the
current location. The
new lines are marked
and may be executed
by pressing Enter.

Paste Unicode [PasteUnicode]

Same as Paste, but
gets the Unicode text
from the clipboard
and converts to ⎕AV

Paste Non-Unicode [PasteAnsi]

Same as Paste, but
gets the ANSI text
from the clipboard
and converts to ⎕AV

Copy Object [ObjCopy]
Copies the contents of
the current object to
the clipboard

Paste Object [ObjPaste]
Pastes the contents of
the clipboard into the
current object

Line Numbers [LineNumbers]
Toggles line numbers
on/off

Align Comments [AlignComments]
Aligns Comments to
current column

Explorer [Explorer]
Displays the
Workspace Explorer

Search [WSSearch]
Displays the Find
Objects tool

Event Viewer [EventViewer]
Displays the Event
Viewer

Threads [Threads]
Displays the Threads
Tool

Status [Status]
Displays the Status
window
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Item Action Description

Colours [ChooseColors]
Displays the Colour
Selection dialog

Interrupt [Interrupt]
Generates a weak
interrupt

Open link [OpenLink]

Opens the URL or
link using the
appropriate program.
Unicode Edition only.

Copy link to clipboard [CopyLink]

Copies the URL or
link to the Windows
Clipboard. Unicode
Edition only.

For the last two items, see Installation & Configuration Guide: Configuration
Dialog: General Tab)
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The Session Toolbars
The Session toolbars are contained by four separate CoolBand objects, allowing you
to configure their order in whichever way you choose. The tool buttons appear
differently according to whether or not Native Look and Feel is enabled.

The bitmaps for the buttons displayed on the session tool bar are implemented by
three ImageList objects owned by the CoolBar ⎕SE.cbtop. These represent the
ToolButton images in their normal, highlighted and inactive states and are named
iln, ilh and ili respectively. These images derive from three bitmap resources
contained in dyalog.exe named tb_normal, tb_hot and tb_inactive.

If Native Look and Feel is enabled all three bitmap resources are mapped to a
different set of images which are capable of reflecting the Visual Styles in use.

Native Look and Feel Enabled

Native Look and Feel Disabled
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Workspace (WS) Operations

Clear Workspace
Executes the system operation [WSClear] which asks
for confirmation, then clears the workspace

Load Workspace

Executes the system operation [WSLoad] which
displays a file selection dialog box and loads the selected
workspace

Copy Workspace

Executes the system operation [WSCopy] which
displays a file selection dialog box and copies the (entire)
selected workspace

Save Workspace
Executes the system operation [WSSaveas] which
displays a file selection dialog box and saves the
workspace in the selected file

Export Workspace

Executes the system operation [MakeExe] which re-
exports the workspace using the settings, parameters and
options that were previously selected using the Create
Bound File dialog

Print Functions

Executes the system operation [PrintFnsInNS] that
prints all the functions and operators in the current
namespace
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Object Operations

Copy Object
Executes the system operation [ObjCopy] which copies
the contents of the current object to the clipboard

Paste Object
Executes the system operation [ObjPaste] which
copies the contents of the clipboard into the current
object, replacing its previous value

Print Object
Executes the system operation [ObjPrint]. Prints the
current object. Note that if the object is being edited, the
version of the object displayed in the edit window is
printed.

Edit Object
Executes the system operation [Edit] which edits the
current object using the standard system editor

Edit Array
Executes a defined function in ⎕SE that edits the current
object using the Array Editor (Unicode Edition) or a
spreadsheet-like interface based upon the Grid object
(Classic Edition). See Array Editor on page 39

SharpPlot

Executes a defined function in ⎕SE that runs the Chart
Wizard to plot the current object using the ]chart User
Command.
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Tools

Explorer

Executes the system operation [Explorer] which
displays the Workspace Explorer tool

Search

Executes the system operation [WSSearch] which
displays the Workspace Search tool

Line Numbers
Executes the system operation [LineNumbers] which
toggles the display of line numbers in edit and trace
windows on and off

Clear all Stops
Executes the system operation [ClearTSM] which
clears all ⎕STOP, ⎕MONITOR and ⎕TRACE settings

Edit Operations

Copy Selection
Executes the system operation [Copy] which copies the
selected text to the clipboard

Paste Selection
Executes the system operation [Paste] which pastes
the text in the clipboard into the current window at the
insertion point

Recall Last
Executes the system operation [Undo] which recalls the
previous input line from the input history stack

Recall Next
Executes the system operation [Redo] which recalls the
next input line from the input history stack
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Session Operations

Load Session
Executes the system operation [SELoad] which
displays a file selection dialog box and loads the
selected Session File

Boxing On/Off
Executes the user command ]boxing to toggle
boxing on/off.

Select Font

Selects the font to be used in the Session window

Select Font Size

Selects the size of the font to be used in the Session
window
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The Session Status Bar
The session status bar is represented by two CoolBands each of which contains a
StatusBar object. There are a number of StatusFields as illustrated below. Your own
status bar may be configured differently.

Classic Edition

Unicode Edition

The StatusField objects owned by the session StatusBar may have special values of
Style, which are used for operations relevant only to the Session. These styles are
summarised in the tables shown below.

Table 19: Session status fields: first row
StatusField Style Description

hint None Displays hints for the session objects, or "Ready..."
when APL is waiting for input

insrep InsRep Displays the mode of the Insert key (Ins or Rep)

mode KeyMode

Displays the keyboard mode. This is applicable
only to a multi-mode keyboard. The text displayed
is defined by the Mn= string in the Input Table.
Classic Edition Only

num NumLock Indicates the state of the Num Lock key. Displays
"NUM" if Num Lock is on, blank if off

caps CapsLock Indicates the state of the Caps Lock key. Displays
"Caps" if Caps Lock is on, blank if off

pause Pause Displays a flashing red "Pause" message when the
Pause key is used to halt session output
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Table 20: Session status fields: second row
StatusField Style Description

curobj CurObj Displays the name of the current object (the
name last under the input cursor)

tc ThreadCount Displays the number of threads currently
running (minimum is 1)

dqlen DQLen Displays the number of events in the APL event
queue

trap Trap Turns red if ⎕TRAP is set

si SI Displays the length of ⎕SI. Turns red if non-
zero

io IO
Displays the value of ⎕IO. Turns red if ⎕IO is
not equal to the value of the default_io
parameter

ml ML
Displays the value of ⎕ML. Turns red if ⎕ML is
not equal to the value of the default_ml
parameter

Toggle Status Fields
In the default Session files distributed with this release, the Statusfields used to
display the value of ⎕IO, the state of the Insert key (Ins/Rep) and the current
keyboard mode (for example, Apl/Uni) have callback functions attached to
MouseDblClick. This means that you can toggle the state of these fields by double-
clicking with the left mouse button.

If you dislike this behaviour, you may set the Event property of the StatusFields to 0
and re-save the Session file. Alternatively, you may modify the buildse workspace
and rebuild the Session from scratch.
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Status Window
The Status window is used to display system messages and supplementary
information. These include the operations that take place when you register an
OLEServer or ActiveXControl.

The Status window is also used to display supplementary information about errors.
For example if you attempt to use a .NET method with incorrect argument(s) you
will get a suitable error message in the Status window, in addition to the DOMAIN
ERROR message in the Session.

Example

⎕USING←'System'
bd←⎕NEW DateTime(2015 4) ⍝ Typo (2015 4 30)

DOMAIN ERROR
bd←⎕NEW DateTime(2015 4) ⍝ Typo (2015 4 30)

∧

The Status window can be explicitly displayed or hidden using the [Status]
system operation which is associated with the Tools/Status menu item. There is also
an option to have the Status window appear automatically whenever a new message
is written to it. This option is selected using the [AutoStatus] system operation
which is associated with the Tools/AutoStatus menu item.

Note that when you close the Status window, all the system messages in it are
cleared.
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The Workspace Explorer Tool
The Explorer tool is a modeless dialog box that may be toggled on and off by the
system action [Explorer]. In a default Session, this is attached to a MenuItem in
the Tools menu and a Button on the session toolbar.

The Explorer contains two sub-windows. The one on the left displays the namespace
structure of your workspace using a TreeView. The right-hand window is a ListView
that displays the contents of the namespace that is selected in the TreeView.

The Explorer is closely modelled on the Windows Explorer in Windows and the
facilities it provides are very similar. For Windows users, the operation of this tool is
probably self-explanatory. However, other users may find the following discussion
useful.
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Exploring the Workspace
The TreeView displays the structure of your workspace. Initially it shows the root
and Session namespaces # and ⎕SE. The icon for # is open indicating that its
contents are those that appear in the ListView. You can expand or collapse the
TreeView of the workspace structure by clicking on the mini-buttons (labelled + and
-) or by double-clicking the icons. A single click on a namespace icon opens it and
causes its contents to be displayed in the ListView. Another way to open a
namespace is to double-click its icon in the ListView. Only one namespace can be
open at a time. The icons used in the display are described below.

Class

Namespace

GUI Namespace

Function

Variable

Operator

Indicates an object that has been erased

Type Library

.NET object
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Viewing and Arranging Objects
The ListView displays the contents of a namespace in one of four different ways
namely Large Icons view, Small Icons view, List Icons view or Details view. You
can switch between views using the View menu or the tool buttons that are provided.
In the first three views, the system displays the name of the object together with an
icon that identifies its type. In Details view, the system displays several columns of
additional information. You may resize the column widths by dragging or double-
clicking the lines in the header. To hide a column, drag its width to the far left. The
additional columns are:

Location
This is the namespace containing the object. By definition, this
is the same for all of the objects shown in the ListView and is
normally hidden.

Type Type of object.

Description

For a function or operator, this is the function header stripped of
localised names and comment. For a variable, the description
indicates its rank, shape and data type. For a namespace, the
description indicates the nature of the namespace; a plain
namespace is described as namespace, a GUI Form object is
described as Form, and so forth.

Size The size of the object as reported by ⎕SIZE.

Modified on For functions and operators, this is the timestamp when the
object was last fixed. For other objects this field is empty.

Modified by For functions and operators, this is the name of the user who last
fixed the object. For other objects this field is empty.

In any view, you may arrange the objects in ascending order of name, size,
timestamp or class by clicking the appropriate tool button. In Details view, you may
sort in ascending or descending order by clicking on the appropriate column heading.
The first click sorts in ascending order; the second in descending order.
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Moving and Copying Objects
You can move and copy objects from one namespace to another using drag-drop or
from the Edit menu.

To move one or more objects using drag-and-drop editing:

1. Select the objects you want to move in the ListView.
2. Point to one of the selected objects and then press and hold down the left

mouse button. When the drag-and-drop pointer appears, drag the object(s) to
another namespace in the TreeView. To indicate which of the namespaces is
the current target, its name will be highlighted as you drag the selected object
(s) over the TreeView.

3. Release the mouse button to drop the objects into place. The objects will
disappear from the ListView because they have been moved to another
namespace.

To copy one or more objects using drag-and-drop editing, the procedure is the same
except that you must press and hold the Ctrl key before you release the mouse button.

You may also move and copy objects using the Edit menu. To do so, select the object
(s) and then choose Move or Copy from the Edit menu. You will be prompted for the
name of the namespace into which the objects are to be moved or copied. Enter the
namespace and click OK.

Editing and Renaming Objects
You can open up an edit window for a function or variable by double-clicking its
icon, or by selecting it and choosing Edit from the Edit menu or from the popup
menu. You may rename an object by clicking its name (as opposed to its icon) and
then editing this text. You may also select the object and choose Rename from the
Edit menu or from the popup menu. Note that when you rename an object, the
original name is discarded. Unlike changing a function name in the editor, this is not
a copy operation.
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Using the Explorer as an Editor
If you open the Fns/Ops item, the names of the functions and operators in the
namespace are displayed below it alphabetically in the left (tree view) pane. When
you select one of these names, the function itself is opened in the right (list view)
pane.

You may use this feature to quickly cycle through the functions (or variables) in a
namespace, pressing cursor up and cursor down in the left (tree view) pane to move
from one to another.

You may also edit the function directly in the right (list view) pane before moving on
to another.
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The File Menu

The File menu, illustrated above, provides the following actions. All but Print setup
and Close act on the object or objects that are currently selected in the ListView.

Print Prints the object(s). Note that if an object is open in the editor,
the version shown in the edit window is printed.

Print setup Displays the Print Configuration dialog box.

Delete Erases the object(s).

Rename Renames the object. This option only applies when a single
object is selected.

Properties Displays a property sheet; one for each object that is selected.

Close Closes the Explorer
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The Edit Menu

The Edit menu, illustrated above, provides the following actions. The Edit, Copy and
Move operations act on the object or objects that are currently selected in the
ListView.

Edit Opens an edit window for each of the objects selected.

Copy Prompts for a namespace and copies the object(s) there.

Move Prompts for a namespace and moves the object(s) there.

Select
Functions Selects all of the functions and operators in the ListView.

Select
Variables Selects all of the variables in the ListView.

Select None Deselects all of the objects in the ListView.

Select All Selects all of the objects in the ListView.

Invert
Selection

Deselects the selected objects and selects all those that were
not selected.
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The Options Menu

The Options menu, illustrated above, provides the following actions.

Toolbar Displays or hides the Explorer toolbar.

Toolbar
Captions Displays or hides the button captions on the Explorer toolbar.

StatusBar Displays or hides the Explorer statusbar.

Type
Libraries Enables/disables the exploring of Type Libraries

Expand All
Expands all namespaces and sub-namespaces in the TreeView,
providing a complete view of the workspace structure, including
or excluding the Session object ⎕SE.

Refresh
Now

Redisplays the TreeView and ListView with the current structure
and contents of the workspace. Used if Auto Refresh is not
enabled.

Auto
Refresh

Specifies whether or not the Explorer immediately reflects
changes in the active workspace.

If Auto Refresh is checked the Explorer is updated every time APL returns to desk-
calculator mode. This means that it is always in step with the active workspace. If
you have a large number of objects displayed in the Explorer, the update may take a
few seconds and you may wish to prevent this by un-checking this menu item  If you
do so, the Explorer must be explicitly updated by selecting the Refresh Now action.



Chapter 1: The APL Environment 77

The View Menu

The View menu, illustrated above, provides the following actions.

Columns Allows you to select which columns you wish to display.

Large
Icons Selects Large Icons view in the ListView.

Small
Icons Selects Small Icons view in the ListView.

List Icons Selects List Icons view in the ListView.

Details Selects Details view in the ListView.

Scope Allows you to choose whether the Explorer displays objects in
local scope or in global scope.

Arrange
Icons Sorts the items in the ListView by name, type, size or date.

Line up
Icons Rearranges the icons into a regular grid.

Auto
Arrange

If checked, the icons are automatically re-arranged when
appropriate

.
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The Tools Menu

The Tools menu, illustrated above, provides the following actions.

Find Displays the Find Objects Tool

Go to Prompts for a namespace and then opens that namespace in the
TreeView, displaying its contents in the ListView

Go to
Session
Space

Opens the namespace in the TreeView control corresponding to
the current space in the Session.

Set Session
Space

Sets the current space in the Session to be the namespace that is
currently open in the TreeView.
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Browsing Classes

Classes are represented by icons. The picture below shows 3 classes: Bird,
Parrot and DomesticParrot.
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If you open the # node in the left-hand pane, you see the contents of # as a tree.
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Browsing Class Scripts
Selecting DomesticParrot in the left-hand pane brings up its Class Script in the
right-hand pane.
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… and selecting Parrot in the left-hand pane brings up the Class Script for
Parrot.
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… and finally, selecting Bird in the left-hand pane brings up the Class Script for
Bird.
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If you open a Class node, a tree appears to help you to navigate within the Class
script. In the picture below, the user has opened the [Methods] node and then
clicked on Speak. The system has responded by scrolling to (if necessary) and
highlighting the appropriate section of the script.
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Browsing Type Libraries
When the View/Type Libraries option is enabled, the Workspace Explorer allows you
to:

l Browse the Type Libraries for all the COM server objects that are installed on
your computer, whether or not they are loaded in your workspace.

l Load Type Libraries for COM objects
l Browse the Type Library associated with an OLEClient object that is already
instantiated in the workspace.

If the Microsoft .NET Framework is installed, you may in addition:

l Load Metadata for specific .NET classes
l Browse the loaded Metadata, viewing information about classes, methods,
properties and so forth.

If the Type Libraries option is enabled, the Workspace Explorer displays a folder
labelled TypeLibs which, when opened, displays two others labelled Loaded
Libraries and Registered Libraries as shown below.
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Browsing Registered Libraries
If you open the Registered Libraries folder, the Workspace Explorer will display in
the tree view pane the names of all the Type Libraries associated with the COM
Server objects that are installed on your computer.

If you select one of these Library names, some summary information is displayed in
the list view pane.

For example, the result of selecting the Microsoft Excel 16.0 Object Library is
illustrated below.

If instead, you select the Registered Libraries folder itself, the list of Registered Type
Libraries is displayed in the list view pane
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Loading a Type Library
You can load a library shown in the tree view pane by selecting Load from its
context menu.

In either case, a message box will appear asking you to confirm. The operation to
load a Type Library may take a few moments to complete.

Notice that if the selected Library references any other libraries, they too will be
loaded. For example, loading the Microsoft Excel 16.0 Object Library brings in the
Microsoft Office 16.0 Object Library and the Microsoft Visual Basic for Applications
Extensibility 5.3 Library too. It also contains references to a general library called the
OLE Automation Type Library, so this is also loaded.

When you )SAVE your workspace, all of the Type Libraries that you have loaded
will be saved with it. Note that type library information can take up a considerable
amount of workspace.
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Browsing Loaded Libraries
If you have already loaded any Type Libraries into the workspace, using the
Workspace Explorer or as a result of creating one or more OLEClient objects, you
can select and open the Loaded Libraries folder.

The picture below illustrates the effect of having loaded the Microsoft Excel 16.0
Object Library.

Notice that any external references to other libraries causes these to be brought in
too.

If you select a loaded Type Library, summary information is displayed in the list
view pane.

If you open a loaded Type Library, four sub-folders appear named Object CoClasses,
Objects, Enums and Event Sets respectively.
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Object CoClasses
A Type Library describes a number of objects. Typically, all of the objects have
properties and methods, but only some of them, perhaps just a few, generate events.
Objects which generate events are represented by CoClasses, each of which has a
pointer to the object itself and a pointer to an event set.

For example, the Microsoft Excel 16.0 Object Library contains seven CoClasses
named Application, Chart, Global etc as shown below.
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Opening the Application folder you can see that the Application CoClass comprises
the _Application object coupled with the AppEvents event set as shown below.

The specific methods, properties and events supported by the CoClass object can be
examined by opening the appropriate sub-folder. The same information for these and
other objects is also accessible from the Objects and Event Sets folders as discussed
below.
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Objects
The Objects folder contains several sub-folders each of which represents a named
object defined in the library.

Each object folder contains two sub-folders named Methods and Properties. Selecting
one of these causes the list of Methods or Properties to be displayed in the list view
pane. The picture below shows the Methods exposed by the Microsoft Excel 16.0
Range object.
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If you open the Methods or Properties subfolder, you can display more detailed
information about individual Methods and Properties. For example, the following
picture shows information about the SaveAs method exposed by the Microsoft Excel
16.0 Worksheet object.

This tells you that the SaveAs method takes up to 10 parameters of which the first,
Filename, is mandatory and is of data type VT_BSTR (a character string). Note that
[in] indicates that the parameter is an input parameter.
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Incidentally, the optional Fileformat parameter is an example of a parameter whose
value must be one of a list of Enumerated Constants. Even without looking at the
documentation, the possible values can be deduced by browsing the Enums folder,
with the results shown below.

You can therefore deduce that the following expression, executed in the namespace
associated with the currently active worksheet, will save the sheet in comma-
separated format (CSV) in a file called mysheet.csv:

SaveAs 'MYSHEET.CSV' xlCSV

or

SaveAs 'MYSHEET.CSV' 6
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Event Sets
The Event Sets folder contains several sub-folders each of which represents a named
set of events generated by the objects defined in the library.

If you open one of these event sets, the names of the events it contains are displayed
in the tree view pane. If you then select one of the events, its details are displayed in
the list view pane as shown below.

This example shows that when it fires, the SheetActivate event invokes your callback
function with a single argument named Sh whose datatype is VT_DISPATCH (in
practice, a Worksheet object).
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Enums
The Enums folder will typically contain several sub-folders each of which represents
a named set of enumerated constants.

If you select one of these sets, the names and values of the constants it contains are
displayed in the list view pane as shown below.
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Browsing .NET Classes
Microsoft supplies a tool for browsing .NET Class libraries called ILDASM.EXE1.

As a convenience, the Dyalog APL Workspace Explorer has been extended to
perform a similar task as ILDASM so that you can gain access to the information
within the context of the APL environment.

The information that describes .NET classes, which is known as its Metadata, is part
of the definition of the class and is stored with it. This Metadata corresponds to Type
Information in COM, which is typically stored in a separate Type Library.

To gain information about one or more .NET Classes, open the Workspace Explorer,
right click the Metadata folder, and choose Load.

1 ILDASM.EXE can be found in the .NET SDK and is distributed with Visual Studio
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This brings up the Browse .NET Assembly dialog box as shown below. Navigate to
the .NET assembly of your choice, and click Open.

The .NET Classes provided with the .NET Framework are typically located in
C:\WINDOWS\Microsoft.NET\Framework64\V4.0.30319 (on a 64-bit
computer). The last named folder is the Version number.

The most commonly used classes of the .NET Namespace System are stored in this
directory in an Assembly named mscorlib.dll, along with a number of other
fundamental .NET Namespaces.
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The result of opening this Assembly is illustrated in the following screen shot. The
somewhat complex tree structure that is shown in the Workspace Explorer merely
reflects the structure of the Metadata itself.
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Opening the System/ Classes sub-folder causes the Explorer to display the list of
classes contained in the .NET Namespace System as shown in the picture below.
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The Constructors folder shows you the list of all of the valid constructors and their
parameter sets with which you may create a new instance of the Class by calling
New. The constructors are those named .ctor; you may ignore the one named .cctor,
(the class constructor) and any labelled as Private.

For example, you can deduce that DateTime.New may be called with three
numeric (Int32) parameters, or six numeric (Int32) parameters, and so forth.
There are in fact seven different ways that you can create an instance of a
DateTime.

For example, the following statement may be used to create a new instance of
DateTime (09:30 in the morning on 30th April 2001):

mydt←⎕NEW DateTime (2001 4 30 9 30 0)

mydt
30/04/2001 09:30:00
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The Properties folder provides a list of the properties supported by the Class. It
shows the name of the property followed by its data type. For example, the
DayOfYear property is defined to be of type Int32.
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You can query a property by direct reference:

mydt.DayOfWeek
Monday

Notice too that the data types of some properties are not simple data types, but
Classes in their own right. For example, the data type of the Now property is itself
System.DateTime. This means that when you reference the Now property, you
get back an object that represents an instance of the System.DateTime object:

mydt.Now
07/11/2001 11:30:48

⎕TS
2001 11 7 11 30 48 0
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The Methods folder lists the methods supported by the Class. The Explorer shows the
data type of the result of the method, followed by the name of the method and the
types of its arguments. For example, the IsLeapYear method takes an Int32
parameter (year) and returns a Boolean result.

mydt.IsLeapYear 2000
1



Chapter 1: The APL Environment 104

Many of the reported objects are listed as Private, which means they are inaccessible
to users of the class – you are not able to call them or inspect their value. For more
information about classes, see Language Reference Guide: Object Oriented
Programming.
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Find Objects Tool
The Find Objects tool is a modeless dialog box that may be toggled on and off by the
system action [WSSearch]. In a default Session, this action is attached to a
MenuItem in the Tools menu and a Button on the session toolbar.

The Find Objects tool allows you to search the active workspace for objects that
satisfy various criteria.

Name
The Named field is used to search for objects with a particular name and is case-
insensitive.

Containing Text
The Containing Text field is used to search for objects that contain a particular text
string. The string search is controlled by the fields Match Case, Use Regular
Expressions, Match Whole Word and As Symbol Reference.

Match Case specifies whether or not the string search (for name and/or contents) is
case sensitive.

Use Regular Expressions specifies whether or not regular expressions are applicable.
For example, if you enter FOO* into the field labelled Containing Text and check this
box, the system will find objects that contain any text string starting with the 3
characters FOO.
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If this box is not checked, the system will find objects that contain the 4 characters
FOO*.

Text searches are performed using PCRE. If the Use Regular Expressions box is
checked, the full range of regular expressions provided by PCRE are available for
use. See Language Reference Guide: Appendix A.

Match Whole Word specifies whether or not the search is restricted to entire words.

As Symbol Reference specifies whether or not the search is restricted to APL
symbols. If so, matching text in comments and other strings is ignored.

Object Criteria
Four check boxes are provided for you to specify the types of objects you wish to
locate. For example, if you clear Variables, Operators and Namespaces, the system
will only search for functions.

To make the search dependent upon modification, you must check the Modified
Objects check box.

To locate objects modified by a particular user, enter the user name in the field
labelled Modified by. Otherwise leave this blank.

To find objects which have been modified at a certain time or within a specified
period of time, check the appropriate radio button and enter the appropriate dates or
time spans.

If you wish to restrict the search to find only objects whose size is within a given
range, check the box labelled Size is between and enter values into the fields
provided.

Location Criteria
You can restrict the search to a particular namespace by typing its name into the field
labelled Look in. You can further restrict the search by clearing the Include sub-
namespaces and Include Session namespace check boxes. Clearing the former
restricts the search to the root namespace or to the namespace that you have specified
in Look in, and does not search within any sub-namespaces contained therein.
Clearing the latter causes the system to ignore ⎕SE in its search.



Chapter 1: The APL Environment 107

When you press the Find Now button, the system searches for objects that satisfy all
of the criteria that you have specified on all 3 pages of the dialog box and displays
them in a ListView. The example below illustrates the result of searching the
workspace for all objects containing references to the symbol Speak.

You may change the way in which the objects are displayed in the ListView using
the View menu or the tool buttons, in the same manner as for objects displayed in the
Workspace Explorer. You may also edit, delete and rename objects in the same way.
Furthermore, objects can be copied or moved by dragging from the ListView in the
Search tool to the TreeView in the Explorer.

If you wish to specify a completely new set of criteria, press the New Search button.
This will reset all of the various controls of the dialog box to their default values.
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Object Properties Dialog Box
The Object Properties dialog box displays detailed information for an APL object. It
is displayed by executing the system action [ObjProps]. In a default Session, this
is provided in the Tools menu, the Session popup menu and from the Explorer. An
example (for a function) is shown below.

Properties Tab
The Properties tab displays general information about the object. For a function, this
includes an extract from its header line, when it was last modified, and by whom.
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Value Tab
For a variable, the Values tab displays the value of the variable. For a function, it
displays its canonical representation.
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Monitor Tab
The Monitor tab applies only to a function and displays the result of ⎕MONITOR.
The Reset button resets ⎕MONITOR for the lines on which it is currently set. The Set
All Lines button sets ⎕MONITOR to monitor all the lines in the function. The Clear
All Lines switches ⎕MONITOR off.
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COM Properties Tab
The COM Properties tab applies only to a function in an OLEServer or
ActiveXControl namespace. The tab is used to define arguments and data types for
an exported Method or Property. For further information, see Interface Guide.
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Net Properties Tab
The Net Properties tab applies only to a function in a NetType namespace. The tab is
used to define arguments and data types for an exported Method or Property. For
further information, see .NET Interface Guide: .
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The Editor
Invoking the Editor
The editor may be invoked in several ways. From the session, you can use the system
command )ED or the system function ⎕ED, specifying the names(s) of the object(s)
to be edited. You can also type the name of the object and then press Shift+Enter
(ED), click the Edit tool on the tool bar, or select Edit from the Action menu. If you
invoke the editor when the cursor is positioned on the empty input line, with a
suspended function in the state indicator, the editor is invoked on the suspended
function and the cursor is positioned on the line at which it is suspended. This is
termed naked edit. These ways of invoking the editor apply only in the session
window

In addition, there is a general point-and-edit facility which works in edit and trace
windows too. Simply position the input cursor over a name and double-click the left
mouse button. Alternatively, you can press Shift+Enter or select Edit from the File
menu. The name can appear in the Session, in an Edit window, or in a Trace window;
the effect is the same. Note that, in the Session, typing a name and pressing
Shift+Enter is actually a special case of point-and-edit. Note also that a naked edit
can be invoked by double-clicking the left mouse button in the empty input line.
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The type of a new object defaults to function/operator unless the object is shadowed,
in which case it defaults to a variable (vector of character vectors). You can however
specify the type of a new object explicitly using )ED or ⎕ED. For example, typing
")ED ∊LIST -MAT" in a CLEAR WS would create Edit windows for a vector of
character vectors named LIST and a character matrix called MAT. See )ED or ⎕ED
for details.

If the name is not already being edited, it is assigned a new edit window. If you edit
a name which is already being edited, the system focuses on the existing edit window
rather than opening a new one. Edit windows are displayed using the colour
combination associated with the type of the object being edited.

If the name is followed by a line-number in square brackets, for example, MyFn
[1000], the Editor will position the cursor on the specified line. This applies to alll
methods of invoking the Editor, except ⎕ED. There must not be a space between the
last character of the name and the "[".
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Window Management (Standard)
Unless Classic Dyalog mode is selected (Options/Configure/Trace/Edit), the Editor is
a Multiple Document Interface (MDI) window that may be a stand-alone window, or
be docked in the Session window. Each of the objects being edited is displayed in a
separate sub-window. Individual edit windows are managed using standard MDI
facilities.

The first edit sub-window window is created at the position specified by the edit_
first_y and edit_first_x parameters which are specified in terms of the size of a
character in the current font relative to the top-left corner of the main Editor window.
Subsequent ones are staggered according to the values of the edit_offset_y and edit_
offset_x parameters.

The initial size of an edit window is specified by the edit_rows and edit_cols
parameters.

Note that the blue triangles indicate that the line of text is longer than can be
displayed in the current Edit window.
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By default, the Session has the Editor docked along the right edge of the Session
window. When you edit a function, the Editor window automatically springs into
view as illustrated below.
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You can resize the Editor pane to view more or less of the Session itself, by dragging
its title bar.

Using the buttons in the title bar, you can instantly maximise the Editor pane to allow
you to concentrate on editing, or minimise it to reveal the entire Session. In either
case, the restore button quickly restores the 2-pane layout.

The picture below shows the effect of maximising the Editor. The BUILD_
SESSION edit window is itself maximised within the Editor too.

Note that when the Editor has the focus, the Editor menubar is displayed in place of
the Session menubar.
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Window Management (Classic Dyalog mode)
If Classic Dyalog mode is selected (Options/Configure/Trace/Edit) each Edit window
is a top-level window created as a child of the Session window. This means that
normally Edit windows appear on top of the Session. However, if the SessionOnTop
parameter is set, the Session window, when given the focus, will appear on top of
Edit windows.

When the first Edit window is opened, its position is determined as follows:

l If the ClassicModeSavePosition parameter is set, the first Edit window is
displayed at the position that was previously occupied by the most recently
saved Edit window.

l If not, the first edit window is created at the position specified by the edit_
first_y and edit_first_x parameters which are specified in terms of the size of
a character in the current font relative to the top-left corner of the screen.

The initial size of an edit window is specified by the edit_rows and edit_cols
parameters.

Subsequent ones are staggered according to the values of the edit_offset_y and edit_
offset_x parameters.
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Moving around an edit window

You can move around in the edit window using the scrollbar, the cursor keys, and the
PgUp and PgDn keys. In addition, Ctrl+Home (UL) moves the cursor to the
beginning of the top-line in the object and Ctrl+End moves the cursor to the end of
the last line in the object. Home (LL) and End (RL) move the cursor to the beginning
and end respectively of the line containing the cursor.

Closing an edit window

Closing an edit window from its System Menu has the same effect as choosing Exit
from the File Menu; namely that it fixes the object in the workspace and then closes
the edit window.

Minimising an edit window

Minimising an edit window causes it to be displayed as a Dyalog Edit icon, with the
name of the object underneath. The edit window can be restored in the normal way,
or by an attempt to re-edit the same name.

Selecting Text
You may select text in an Editor window by clicking the left or right mouse button
over any character, dragging out a highlighed area, and then releasing the mouse
button. When using the left button, moving up or down one line extends the selection
from the beginning of that line, so the selection may be ragged. The right button
selects a rectangularr box.
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Editor ToolBar

In the table below, the first image shows the appearance of the toolbutton with Native
Look and Feel enabled; the second with it disabled.

Button Description

Toggle line numbers
Toggles Line numbers on/off

Toggle tree view
Toggles the treeview on/off. See
Editing Classes on page 142.

Previous Location
Certain operations (such as
selecting an item in the treeview)
reposition the caret in the Editor
window. This button moves the
caret back to its previous location.

Comment selected text
Inserts a comment symbol to the
left of the selection in each of the
selected lines.

Uncomment selected text
Removes the comment symbol (if
present) from the left-most column
of the selection in each of the
selected lines.

Save changes and return
Saves changes and closes the
current edit window

Search Box

Enter search text and click one of
the following two buttons

Search for Next Match
Locates the next occurrence of the
search text
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Button Description

Search for Previous Match
Locates the previous occurrence of
the search

Search hidden text
Determines whether or not the
search examines collapsed blocks

Match case
Specifies whether or not the search
is case-sensitive

Match whole word
Specifies whether or not the search
matches a whole word

Use Regular Expressions
Specifies whether or not the search
uses PCRE regular expressions

Refactor text as method
Inserts a Method template for the
selected name

Refactor text as field
Inserts a Field template for the
selected name

Refactor text as property
Inserts a Property template for the
selected name
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The File Menu

The File menu illustrated above is displayed when editing a simple object and
provides the following options.
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Item Description

Fix

Fixes the object in the workspace, but leaves the edit
window open. Edit history is also preserved. If the data
has changed and the confirm_fix parameter is set, you
will be prompted to confirm.

Fix whole script (Disabled unless editing a script)

Open File Allows you to edit a Dyalog script file or an arbitrary
text file.

Save Saves the file being edited.

Save As Renames and saves the file being edited.

Always ask on close Toggles the value of the confirm_fix parameter.

Edit Opens an Edit window on the name under the cursor
(Disabled when there is no such name).

Print Prints the current contents of the edit window

Print Setup Displays the Print Configuration dialog box

Properties Displays the Object Properties dialog box for the
current object

Exit (and Fix)
Fixes the object in the workspace and closes the edit
window. If the data has changed and the confirm_exit
parameter is set, you will be prompted to confirm

Exit (and fix script) (Disabled unless editing a script)

Exit and discard
changes

Closes the edit window, but does not fix the object in
the workspace. If the data has changed and the
confirm_abort parameter is set, you will be prompted
to confirm.
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The File Menu (editing a script)

Fix whole script Fixes the entire script

Fix only functions Fixes only the functions in the script.

Exit and fix whole
script Fixes the entire script, and exits the Editor.

Exit and fix only
functions

Fixes only the functions in the script and exits the
Editor.
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Editing Scripts

Suppose that you have a Class that manages a list of items in a shared Field, so
somewhere in the script would appear a line such as:-

:Field shared public List←⍬

You run your application for a bit, and List, which was initially empty, gets
updated as new instances of the Class are created. You then edit the Class to add a
new function, or fix a bug. In this instance, when you exit the editor you may not
want List to be reset back to the empty vector although you do want the new
version of the function(s) in the Class to be fixed.

Nevertheless whenever you edit the Class when it is not suspended, you probably
always want the entire script to be re-fixed, and List re-initialised.

The options in the File menu shown above provide for these alternatives.

In addition, the Configuration Dialog (see Installation & Configuration Guide:
Configuration Dialog: Trace/Edit Tab) allows you to define the behaviour of the
keystrokes <EP> and <S1> for both the suspended case and the non-suspended case.
This association will be displayed against the appropriate action according to the
state of the script you are editing.
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The Edit Menu
The Edit menu provides a means to execute those commands that are concerned with
editing text. The Edit menu and the actions it provides are described below.
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Item Description

Reformat Reformats the function body in the edit window,
indenting control structures as appropriate.

Reformat Scripts
Automatically

If checked, the Editor will automatically reformat a
Dyalog script when it loads it.

Undo
Undoes the last change made to the object. Repeated use
of this command sequentially undoes each change made
since the edit window was opened.

Redo
Re-applies the previous undone change. Repeated use of
this command sequentially restores every undone
change.

Select All Selects and highlights the entire contents of the Edit
window.

Cut Copies the selected text to the clipboard and removes it
from the object.

Copy Copies the selected text to the clipboard.

Paste Copies the text in the clipboard into the object at the
current location of the input cursor.

Paste Unicode Same as Paste, but gets the Unicode text from the
clipboard and converts to ⎕AV

Paste Non-Unicode Same as Paste, but gets the ANSI text from the
clipboard and converts to ⎕AV.

Clear Deletes the selection or the character under the cursor.
Has no effect on the clipboard

Open Line Inserts a blank line immediately below the current one.

Delete Line Deletes the current line.

Goto Line Prompts for a line number, then positions the cursor on
that line.

Find Displays the Find dialog box.

Replace Displays the Replace dialog box.

Highlight All
Matches

If checked, all strings in the object being edited that
match the search string are highlighted. The
highlightedted items change dynamically as the search
string is entered or changed.
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Item Description

Comment selected
lines

Adds a comment symbol to the beginning of all selected
lines.

Uncomment selected
lines

Removes a comment symbol from the beginning of all
selected lines.

Toggle Local name Adds or removes the name under the cursor to/from the
function header line.

The Find and Replace items are used to display the Find dialog box and the
Find/Replace dialog box respectively. These boxes are used to perform search and
replace operations and are described later in this Chapter.

Once displayed, each of the two dialog boxes remains on the screen until it is either
closed or replaced by the other. This is convenient if the same operations are to be
performed over and over again, and/or in several windows. Find and Find/Replace
operations are effective in the window that previously had the focus.

The Syntax Menu

The Syntax menu illustrated above provides options to specify how the data displayed
in the Editor window is to be syntax coloured. For workspace objects, the default is
APL for functions and operators, and Nothing for variables.

Item Syntax Colour as

Nothing Variable

APL Function

JSON JSON array

XML XML array
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The Window Menu
The Window menu provides a means to control the display of the various edit
windows. The Window menu and the actions it provides are described below.

Item Description

Close All Windows
Closes all the edit windows. If Confirm on Edit Window
Closed is checked, you will be prompted to confirm for
any objects that you have changed.

Cascade Arranges the edit windows in overlapping fashion.

Tile Vertically Arranges the edit windows tiled one above the other.

Tile Horizontally Arranges the edit windows tiled alongside one another.

Arrange Icons Arranges any minimised edit windows.

Editor Allows you to Select the edit window corresponding to
the named object.
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The Refactor Menu

The Refactor menu illustrated above applies only when editing a Class and provides
the following options. In each case, the user must highlight a name in the Edit
window, and then select one of these options to insert the appropriate template for
that name into the body of the Class.

Item Description

Add text as Field Inserts a Field template for the selected name.

Add text as Property Inserts a Property template for the selected name.

Add text as Method Inserts a Method template for the selected text name.
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The View Menu

The View menu, illustrated above, provides the following actions.

Item Description

Trace Displays a column to the left of the function that
displays ⎕TRACE settings

Stop Displays a column to the left of the function that
displays ⎕STOP settings

Monitor Displays a column to the left of the function that
displays ⎕MONITOR settings

Line Numbers Toggles the display of line numbers on/off.

Function Line
Numbers

Toggles the display of line numbers on individual
functions on/off. This option is only enabled when
editing a Class, Namespace script or Interface.

Tree View Toggles the display of the treeview in the left-hand
pane.

Compiler Errors

If enabled, the Editor identifies which lines of code
would not compile. These are identified by a red
vertical line to the left. Hovering over the red bar gives
you a pop-up telling you what the compiler didn't like
about that line of the function.
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Item Description

Outlining Turns outlining on and off.

Expand All Outlines Expands all outlines.

Collapse All Outlines Collapses all outlines

Expand all Outlines
below here Expands all outlines below the level of the current line.

Function Line Numbers

The Function Line Numbers option in the Editor menu provides an additional level of
line-numbering. If selected, line numbers are displayed independently on each
individual function (or operator) in the Class. This option is only enabled when you
are editing a Class, Namespace script or Interface, and is disabled for all other types
of object.

Note that function line-numbering and general line-numbering are independent
options and it is possible to have the entire Class numbered (from [0] to the number
of lines in the Class) in addition to having line-numbering on each individual
function.
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Using the Editor
Creating a New Function

Type the name of your function and invoke the editor. To do this you may press
Shift+Enter, or select Edit from the Action menu, or double-click the left button on
your mouse, or click the Edit tool in the tool bar. A new window will appear on the
screen with the name you have chosen displayed in the top border. The name is also
inserted in the function header and the cursor positioned to the right. The new
window is automatically given the input focus.

Line-Numbers on/off

Try changing the line numbers setting by clicking on the Line Numbers option in the
Options menu. Note that line-numbering on/off is effective for all edit windows.

Adding Lines

If the keyboard is in Insert mode, pressing Enter at the end of a line opens you a new
blank line under the current one and positions the cursor there ready for input. You
can also open a new blank line by pressing Ctrl+Shift+Insert (OP).

If the cursor is at the end of the last line in the function, pressing Enter adds another
line even if the keyboard is in Replace mode.

Indenting Text

Dyalog allows you to insert leading spaces in lines of a function and (unless the
AutoFormat parameter is set) preserves these spaces between editing sessions.
Embedded spaces are however discarded. You can enter spaces using the space bar or
the Tab key. Pressing Tab inserts spaces up to the next tab stop corresponding to the
value of the TabStops parameter. If the AutoIndent parameter is set, new lines are
automatically indented the same amount as the preceding line.

Reformatting

The RD command (which by default is mapped to Keypad-Slash) reformats a
function according to your AutoFormat and TabStops settings. See Installation &
Configuration Guide: Configuration Dialog: Trace/Edit Tab.

Deleting Lines

To delete a block of lines, select them by dragging the mouse or using the keyboard
and then press Delete or select Clear from the Edit menu. A quick way to delete the
current line without selecting it first is to press Ctrl+Delete (DK) or select Delete
Line from the Edit menu.
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Copying Lines

Select the lines you wish to copy by dragging the mouse or using the keyboard. Then
press Ctrl+Insert or select Copy from the Edit menu. This action copies the selection
to the clipboard. Now position the input cursor where you wish to make the copy and
press Shift+Insert, or select Paste from the Edit menu. You can also use this method
to duplicate a ragged block of text.

To copy text using drag-and-drop editing:

1. Select the text you want to move.
2. Hold down the Ctrl key, point to the selected text and then press and hold

down the left mouse button. When the drag-and-drop pointer appears, drag the
cursor to a new location.

3. Release the mouse button to drop the text into place.

Moving Lines

Select the lines you wish to copy by dragging the mouse or using the keyboard. Then
press Shift+Delete or select Cut from the Edit menu. This action copies the selection
to the clipboard and removes it. Now position the input cursor at the new location
and press Shift+Insert, or select Paste from the Edit menu. You can also use this
method to move a ragged block of text.

To move text using drag-and-drop editing:

1. Select the text you want to move.
2. Point to the selected text and then press and hold down the left mouse button.

When the drag-and-drop pointer appears, drag the cursor to a new location.
3. Release the mouse button to drop the text into place.

Joining and Splitting Lines

To join a line to the previous one: select Insert mode; position the cursor on the first
character in the line; press Bksp.

To split a line: select Insert mode; position the cursor at the place you want it split;
press Return.

Toggling Localisation

The TL command (which by default is mapped to Ctrl+Up) toggles the localisation
of the name under the cursor. If the name is currently global, pressing Ctrl+Up
causes the name to be added to the list of locals in the function header. If the name is
already localised, pressing Ctrl+Alt+l removes it from the header.
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Matching Occurences

When you position the caret over a name, control word, or simple text or to the right
of a parenthesis, bracket, or brace, matching occurrences are identified (by a thin
box). In particular :

l matching occurrences of the word under the caret (except the actual instance
under the caret)

l matching parentheses, brackets and braces
l all control words associated with the one under the caret. For example, if the
caret is on :If, then nested :AndIf, :OrIf, :Else and the final :Endif
are identified.

Aligning Comments

When you press the <AC> key, or select Align Comments in the Editor's context
menu, the alignment of the comments in every line in the function will be changed so
that the left-most comment (Lamp) symbol is in the same column as the cursor,
except that:

l Comment symbols that are preceded only by white space, that is, comments in
lines that contain no code, are ignored and are not adjusted in any way.

l Comment symbols that lie between the first column and the first tab stop will
remain in or be moved to the first column. For information on setting tab
stops, see Installation & Configuration Guide: Configuration Dialog
(Edit/Trace Tab).

l Comment symbols will not move further left than the end of the statement.

When a comment is re-aligned, text to the right of the left-most comment symbol
(including spaces and other comment symbols) will remain fixed in relation to that
symbol.

Note that there is no keystroke associated with this command by default; the user
must define one. See Installation & Configuration Guide: Configuration Dialog
(Keyboard Shortcuts Tab).
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Stop, Trace and Monitor Controls

If any of the Stop, Trace, and Monitor options of the View menu are set, the Editor
displays an area to the left of the function body containing up to 3 columns. If a
function line is enabled by ⎕TRACE,⎕STOP or ⎕MONITOR the corresponding
column displays a yellow circle (trace), red circle (stop) or clock symbol (monitor).

When you move the mouse-pointer over this area, the pointer displays the appropriate
symbol and you can toggle the corresponding setting on and off by clicking the
mouse.

White Space in Source Code
Settings that impact the automatic reformatting of code can cause changes to
whitespace – this can be interpreted as changes to the source code. This means that:

l opening a scripted object in the Edit window can cause the source of that
object to change (when closing an Edit window, you might be prompted to
save a function even though you have not made any changes to it).

l viewing an object can change its file timestamp; source code management
systems can subsequently report changes due to the changed file timestamp.

l source code changes resulting from reformatting will be evident in the results
of system functions such as ⎕AT, ⎕SRC, ⎕CR, ⎕VR and ⎕NR.
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Outlining
When you are editing a function, outlining identifies the blocks of code within
control structures, and allows you to collapse and expand these blocks so that you
can focus your attention on particular parts of the code

The picture below shows the result of opening the function ⎕SE.cbtop.TB_
POPUP.

)ed ⎕SE.cbtop.TB_POPUP

Notice that the various control structure blocks are delineated by a treeview diagram.

l When you hover the mouse pointer over one of the boxes that mark the start
of a block, the line marking the extent of that block becomes highlighted, as
shown above.

l If you click on a box, the corresponding section collapses, so that only the
first line of the block is displayed, as shown below.

l If you click on a box, the corresponding section is expanded.
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Sections
Functions and scripted objects (classes, namespaces etc.) can be subdivided into
Sections with :Section and :EndSection statements. Both statements may be
followed by an optional and arbitrary name or description. The purpose is to split the
function up into sections that you can open and close in the Editor, thereby aiding
readability and code management. Sections have no effect on the execution of the
code, but must follow the nesting rules of other control structures.

The following picture illustrates the use of sections in a function called
DumpWindow. The function is divided into 5 sections named Comments, Init,
NAs, MakeBitmap and CopyToClipBoard.

The first picture shows the function with all sections closed.
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The next picture shows the effect of opening the Comments section. Notice how this
is delineated by the statements:

:Section Comments
...
:EndSection Comments

And with the Init section opened too:
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Finally, with all the sections opened:
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Editing Classes
The picture below shows the result of opening the ComponentFile class. Notice
how each function is delineated separately and that each function is individually line-
numbered.

)ed ComponentFile
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The outlining feature really comes into its own when editing classes because you can
collapse and expand whole functions. The picture below shows the effect of
collapsing all but the Append method.
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When you edit a class, a separate treeview is optionally displayed in the left pane to
make it easy to navigate within the class. When you click on a name in the treeview,
the editor automatically scrolls the appropriate section into view (if necessary) and
positions the edit cursor at its start. The picture below illustrates the result of opening
the [Methods] section and then clicking on Rename.
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Sections within Scripts
Scripts can also be subdivided into Sections using :Section and :EndSection
statements. As with single functions, the purpose is only to split the script up into
sections that you can open and close in the Editor. Sections have no effect on the
execution of the code.

The following picture illustrates a Class named actuarial which, for editing
purposes, has been sub-divided into five separate Sections named Main,
MenuHandlers, Validation, Utilities and OldCode. In this picture, all
the Sections are closed.
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The next picture shows the effect of opening just the Main section.

Notice that this section is delimited by the two statements:

:Section Main
...
:EndSection Main

In this picture the 3 functions within the Main section are temporarily closed.

Similarly, the section called Validation is delimited by:

:Section Validation
...
:EndSection Validation
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Find and Replace Dialogs
The Find and Find/Replace dialog boxes are used to locate and modify text in an
Edit window.
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Search For

Enter the text string that you want to find. Note that the text
from the last 10 searches is available from the drop-down list.
If appropriate, the search text is copied from the Find Objects
tool. This makes it easy to first search for functions
containing a particular string, and then to locate the same
string in the functions.

Replace With
Enter the text string that you want to use as a replacement.
Note that the text from the last 10 replacements is available
from the drop-down list.

Match Case Check this box if you want the search to be case-sensitive.

Match Whole
Word

Check this box if you want the search to only match only
whole words.

Use Regular
Expressions Check this box if you want to use Regular Expressions.

Move Dialog if
Hiding Match

If checked, the Find or Find/Replace dialog box will
automatically position itself so as not to obscure a matched
search string in the edit window.

Find Next After
Replace

If checked, following a replace operation, the selection will
move to the next occurrence of the target string in the edit
window.

Direction Select Up or Down to control the direction of search.
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Using Find and Replace
Find and Replace work on the concept of a current search string and a current
replace string which are entered using the Find and Find/Replace Dialog boxes.
These boxes also contain buttons for performing search/replace operations.

Suppose that you want to search through a function for references to the string
"Adam". It is probably best to work from the start of the function, so first position
the cursor there (by pressing Ctrl+Home). Then select Find from the Edit menu. The
Find Dialog box will appear on your screen with the input cursor positioned in the
edit box awaiting your input. Type "Adam" and click the Find Next button (or press
Return), and the cursor will locate the first occurrence. Clicking Find Next again will
locate the second occurrence. You can change the direction of the search by selecting
Up instead of Down. You could search another function for "Adam" by opening a
new Edit window for it and clicking Find Next. You do not have to redefine the
search string.

Now let us suppose that you wish to replace all occurrences of "Adam" with
"Amanda". First select Replace from the Edit menu. This will cause the Find Dialog
box to be replaced by the Find/Replace Dialog box. Enter the string "Amanda" into
the box labelled ReplaceWith, then click Replace All. All occurrences of "Adam" in
the current Edit window are changed to "Amanda". To repeat the same global change
in another function, simply open an edit window and click Replace All again. If
instead you only want to change particular instances of "Adam" to "Amanda" you
may use Find Next to locate the ones you want, and then Replace to make each
individual alteration.

Text searches are performed using PCRE. If the Use Regular Expressions box is
checked, the full range of regular expressions provided by PCRE are available for
use. See Language Reference Guide: Appendix A.

Saving and Quitting
To save the function and terminate the edit, press Esc (EP) or select Exit from the
File menu. The new version of the function replaces the previous one (if any) and the
edit window is destroyed.

Alternatively, you can select Fix from the File menu. This fixes the new version of
the function in the workspace, but leaves the edit window open. Note that the history
is also retained, so you can subsequently undo some changes and fix the function
again.

To abandon the edit, press Shift+Esc (QT) or select Abort from the File menu. This
destroys the edit window but does not fix the function. The previous version (if any)
is unchanged.
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Editing Scripts and Text Files
The Editor may also be used to edit Dyalog script files (.dyalog files) and general
text files.

There are two ways to choose the file to be edited. If the file exists, you can select it
from the Open source file dialog by clicking File/Edit Text File from the Session
menu bar.

Alternatively, type )ED followed by the pathname to the file. To identify the name
given as a file, it must either contain a slash character ("\" or "/") or be preceded by
one.

Examples

)ED c:\myfiles\myscript.dyalog

)ED c:\myfiles\pete.txt

)ED \x.txt ⍝ x.txt in current directory

)ed / x.txt ⍝ ditto

If the named file does not exist, you will be asked whether or not you want to create
it:

If you edit a Dyalog script file, the editor will treat it as such and provide the same
formatting and syntax colouring as if it were a script in the workspace.

Otherwise, the file will be edited as if it were a character vector with embedded new-
lines.

When you exit the editor with Exit and fix, you will be offered a number of
alternatives depending upon the type of file, as shown below.
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Saving a Text file.

Note that if you choose Save as text in the workspace, information about the file and
the text variable associated with it is retained in the workspace. This information may
be obtained using 5176⌶ and 5177⌶. See Language Reference Guide: List Loaded
Files and List Loaded File Objects.
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Saving a Script file.

Note that if you choose Fix as code in the workspace or Save as text in the
workspace, information about the file and the text variable associated with it is
retained in the workspace. This information may be obtained using 5176⌶ and
5177⌶. See Language Reference Guide: List Loaded Files and List Loaded File
Objects.
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Fix as code in the workspace
If you choose this option, the file will be updated and the script will also be fixed in
the workspace. Note that if the script refers to a base class or other external elements,
it cannot be fixed unless these elements are also present in the workspace.

Save as text in the workspace
If you choose this option, the file will be updated and the contents of the file will
also be saved to a variable in the workspace. First you will see the following warning
dialog, which may be disabled subsequently by checking Do not ask this question
again.

Then you will be prompted to supply its name, which may be a new name or the
name of an existing variable:

Only save file to disk
If you choose this option, the file will be updated but nothing will be changed in the
workspace.

Discard changes
If you choose this option, all changes will be discarded and nothing saved.
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Source as Typed
Historical Introduction
When an object containing executable code such as a function, operator, class, or
namespace is defined in a workspace either by an editor or by the system function
⎕FX, the object is tokenised into an internal form. Historically, this was the only
form of the object, and both the editor and system functions like ⎕CR, ⎕VR, ⎕NR
reconstitute the source code from the internal form. This reconstituted source lacks
extraneous white space and the precise numerical formatting that the user originally
entered, for example.

When classes and scripted namespaces were introduced, the source code was stored
in text form for these objects, as it was typed, in addition to the tokens which were
still used at runtime. The function ⎕SRC was added to return this text, and a new
function ⎕FIX was added to define objects that also have source code.

Subsequently, ⎕FIX was extended to allow the definition of functions and operators
which include source code, as well as the use of source files outside the workspace to
store the source code of an object. However, unless a function or operator was
defined using an external file, the editor continued to only store the tokenised form in
the workspace, in order to save space.

Current Behaviour
From version 19.0 onwards, the default is that the editor stores source code as it was
typed in by the user for all objects, in addition to the tokenised form. When an object
is defined from an external source file using ⎕FIX, a copy of the source is also
retained in the workspace.

In order to maintain backwards compatibility with applications that rely on the
canonical representation returned by ⎕CR, ⎕VR , ⎕NR, these functions continue to
reconstitute the source from tokens; and ⎕FX continues to only store the tokenised
form. If you wish to access the source as typed, you should use ⎕SRC, or 60 ⎕ATX,
and you should use ⎕FIX, to define not only namespaces and classes but functions
and operators as well.

When the user opens an object in the Editor, the saved source code is presented if it
exists. If the object was defined from a file and the source held in the workspace
differs from the contents of the file, the user will be asked to decide whether to use
the file or break the link and use the source in the workspace. If no source code is
available, it is reconstituted from the internal form.
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Note however, that there is no mechanism to reconstitute a script, as a whole, from
its tokenised form. If there is no source code, the Namespace or Class appears as if it
were created using ⎕NS rather than having originated from a script. It cannot be
opened in the Editor and the result of ⎕SRC is empty. However, the source code for
individual functions and operators within the Namespace or Class will be
reconstituted from their individual tokenised code when required.

The functions ⎕SRC and 62 ⎕ATX (most precise available source) use the same
logic as described above to generate a result.

Source code saved in the workspace is compressed to minimise space usage.

Note that the white space in comment statements is retained in both the compiled
form and compiled form of a function.

The Boolean parameter DYALOG_DISCARD_FN_SOURCE (default 0) and
5172⌶ (Discard Source Information) allow the user to enable or disable this feature
for functions and operators. The AutoFormat Functions option is automatically
disabled if the DYALOG_DISCARD_FN_SOURCE parameter is 1. Note that the
user can format code on demand).

5171⌶ (Discard Source Information) discards source code and file information for
scripted objects, namespaces, classes, functions, and operators that is saved in the
workspace.

Note that, to ensure that they can be used by Classic Edition, the source code has
been discarded from all the workspaces supplied by Dyalog as part of the
distribution.

See also Language Reference Guide: Discard Source Code and Discard Source
Information.
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The Tracer
The Tracer is a visual debugging aid that allows you to step through an application
line by line. During a Trace you can track the path taken through your code, display
variables in edit windows and watch them change, skip forwards and backwards in a
function. You can cutback the stack to a calling function and use the Session and
Editor to experiment with and correct your code. The Tracer may be invoked in
several ways as discussed below.

Tracing an expression
Firstly, you may explicitly trace an expression that executes one or more defined
functions or operators by typing the expression then pressing Ctrl+Enter (TC) or by
selecting Trace from the Action menu. This lets you step through the execution of an
expression from the beginning.

In the same way as when you execute a statement by pressing Enter, the expression is
(if necessary) copied down to the input line and then executed. However, if the
expression includes a reference to an unlocked defined function or operator,
execution halts at its first line and a Trace window containing the suspended function
or operator is displayed on the screen. The cursor is positioned to the left of the first
line which is highlighted.

Naked Trace
The second way to invoke the Tracer is when you have a suspended function in the
state indicator and you press Ctrl+Enter (TC) on the empty input line. This is termed
naked trace. The same thing can be achieved by selecting Trace from the Action
menu on the Session Window.

The effect of naked trace is to open the Tracer and to position the cursor on the
currently suspended line. It is exactly as if you had traced to that point from the Input
Line expression whose execution caused the suspension.

Automatic Trace
The third way to invoke the Tracer is to have the system do it automatically for you
whenever an error occurs. This is achieved by setting the Show trace stack on error
option in the Trace/Edit tab of the Configuration dialog (Trace_on_error
parameter). When an error occurs, the system will automatically deploy the Tracer.
Note that this means that when an error occurs, the Trace window will then receive
the input focus and not the Session window.
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Tracer Options
From Version 10.1 onwards, the Tracer is designed to be docked in the Session
window.

In previous versions of Dyalog, the Tracer was implemented as a stack of separate
windows (one per function on the calling stack) or as a single, but still separate,
window.

You can disable the standard behaviour by selecting Classic Dyalog mode from the
Trace/Edit tab of the Configuration dialog box.

If you do so, you may then choose to have the Tracer operate in multiple windows or
in a single window.

These alternatives are discussed later in this Chapter.

The Trace Window
The Tracer is implemented as a single dockable window that displays the function
that is currently being executed. There are two subsidiary information windows
which are also fully dockable. The first of these (SIStack) displays the current
function calling stack; the second (Threads) displays a list of running threads.

In the default Session files, the Tracer is docked along the bottom edge of the Session
window. When you invoke the Tracer, it springs up as illustrated below. In this
example, the function being traced is ⎕SE.UCMD, which is invoked by typing a user-
command, in this case ]display.

In the default layout, the SIstack window is displayed alongside the main Tracer
window, although this can be hidden or made to appear as a separate floating
window, as required.
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Trace Tools
The Tracer may be controlled from the keyboard, or by using the Trace Tools which
are arranged along the title bar of the Debugger window. Note that the button names
are solely for reference purposes in the description that follows.

Button Name Key
Code Keystroke Description

Exec ER Enter Execute expression

Trace TC Ctrl+Enter Trace expression

Back BK Ctrl+Shift+Bksp Go back one line

Fwd FD Ctrl+Shift+Enter Skip current line

Continue BH Stop on next line of
calling function

Restart RM →⎕LC Continue execution of
this thread

Restart all Continue execution of
all threads

Edit ED Shift+Enter Edit name

Exit EP Esc Quit this function

Intr Ctrl+Pause Interrupt
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Button Name Key
Code Keystroke Description

Reset CB Clear
trace/stop/monitor for
this object

LN Toggle line numbers

Search for next match

Search for previous
match

Search hidden text

Match case

Match whole word

Use Regular
Expressions

Using the Trace Tools, you can single-step through the function or operator by
clicking the Exec and/or Trace buttons. If you click Exec the current line of the
function or operator is executed and the system halts at the next line. If you click
Trace, the current line is executed but any defined functions or operators referenced
on that line are themselves traced. After execution of the line the system again halts
at the next one. Using the keyboard, the same effect can be achieved by pressing
Enter or Ctrl+Enter.

The illustration below shows the state of execution having clicked Exec 16 times to
reach ⎕SE.UCMD[17].
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Execution Reached ⎕SE.UCMD[35]

The next illustration shows the result of clicking Trace at this point. This caused the
system to trace into ⎕SE.SaltUtils.Spice, the function called from
⎕SE.UCMD[35].

Notice how each function call on the stack is represented by an item in the SIstack
window.
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Execution Reached ⎕SE.SALTUtils.Spice[1]
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The illustration below shows the state of execution having traced deeper into the
system.

Execution reached four levels deep

At this stage, the state indicator is as follows:

)SI
⎕SE.SALT.Load[1]*
⎕SE.SALTUtils.Spice[249]
⎕SE.UCMD[35]
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Controlling Execution
The point of execution may be moved by clicking the Back and Fwd buttons in the
Trace Tools window or, using the keyboard, by pressing Ctrl+Shift+Bksp and
Ctrl+Shift+Enter. Notice however that these buttons do not themselves change the
state indicator or the display in the SIStack window. This happens only when you
restart execution from the new point.

You can cut back the stack by clicking the <EP> button in the Trace Tools window.
This causes execution to be suspended at the start of the line which was previously
traced. The same effect can be achieved using the keyboard by pressing Esc. It can
also be done by selecting Exit from the File menu on the Trace Window or by
selecting Close from its system menu.

The <RM> button removes the Trace window and resumes execution. The same is
achieved by the expression →⎕LC.

The <BH> button continues execution until the current function has run to
completion and control has returned to the calling function. It leaves the Trace
window displayed and allows you to watch execution progress.

Using the Session and the Editor
Whilst using the Tracer you can skip to the Session or to any Edit window and back
again. While it is docked, you may resize the Tracer pane by dragging its title bar,
and you may use the buttons provided to maximise, minimise and restore the Tracer
pane within the Session window.

Unless you move it, the cursor is positioned to the left of the suspended line in the
top Trace window.

Depending where the cursor is in the tracer window, pressing Shift+Enter (ED) or
selecting Edit from the File menu may cause an edit window to open. If the cursor is
in the first column of the Trace window, or on whitespace, the Editor is opened on
function or operator on top of the stack. If the cursor in on a name, the Editor is
opened on the name under the cursor (point-and-edit). With the cursor in any other
location, no action is undertaken.

When you finish editing, the window reverts to a trace window with the new
definition of the function or operator displayed.

You may also open a new edit window from within the Tracer using point-and-edit.

You can copy text from a trace window to the session for editing and execution or
for experimentation.

It is possible to skip from the Tracer to the Session and then re-invoke the Tracer on
a different expression.
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Setting Break-Points
Break-points are defined by ⎕STOP and may be toggled on and off in an Edit or
Trace window by clicking in the appropriate column. The example below illustrates a
function with a ⎕STOP break-point set on line [5].

⎕STOP break-points set or cleared in an Edit window are not established until the
function is fixed. ⎕STOP break-points set or cleared in a Trace window are
established immediately.

Clearing All Break-Points

You can clear all break-points by pressing the above button in the Trace Tools
window. This in fact resets ⎕STOP for all functions in the workspace.
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The Classic mode Tracer
If you select Classic Dyalog mode from the Trace/Edit tab in the Configuration
dialog box, the Tracer behaves in the same way as in Dyalog version 8.2. However,
the Tracer is not dockable in the Session.

If you select the Classic mode Tracer, you may choose between multiple trace
windows or a single trace window using the Single Trace Window option.

Multiple Trace Windows
The following behaviour is obtained by deselecting the Single Trace Window option.

l Each function on the SI stack is represented by a separate trace window. The
top window contains the function that is currently executing, other windows
display functions further up the stack, in the order in which they were called.

l When you press Ctrl+Enter or click the Trace button on a line that calls
another function, a new trace window appears on top of the stack and displays
the newly called function.

l When a function exits, its trace window disappears and the focus moves to the
previous trace window. When the last function in a traced suspension exits,
the last trace window disappears.

l If you click the Quit this function button in the Trace Tools window, or press
Escape, or close the trace window by clicking on its [X] button or typing Alt-
F4, the top trace window disappears and the focus moves to the previous trace
window

l If you close any of the trace windows further down the stack, the stack will be
cut back to the corresponding point, that is, to the line of code that called the
function whose trace window you closed.

l The <RM> button removes all the trace windows and resumes execution. The
same is achieved by the expression →⎕LC. The <CS> button also continues
execution, but leaves the trace windows displayed and allows you to watch
their progress.

l If you minimise any of the trace windows, the entire stack is minimised to a
single icon, from which it may be restored.

l If you drag any Trace window with the mouse and at the same time press
Ctrl+Shift, the entire set of Trace windows is dragged.

Note that a maximum of 50 Trace windows may be displayed.
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Single Trace Window
The following behaviour is obtained by selecting the Single Trace Window option.

l The trace window contains a combo box whose drop-down displays the
contents of the SI stack. This box is not provided if there are multiple trace
windows.

l The trace window is re-used when tracing into, or returning from, a called
function. This means that there is never more than one trace window present.

l When the last function in a traced suspension exits, the trace window
disappears.

l If you click the Quit this function button in the Trace Tools window, or press
Escape, the current function is removed from the stack and the trace window
reused to display the calling function if there is one.

l Closing the trace window by clicking on its [X] button or typing Alt-F4
removes the window and clears the current suspension. It is equivalent to
typing naked branch (→) in the session window.

l If you move or resize the trace window, APL remembers its position, so that it
reappears in the same position when next used.
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The Threads Tool
The Threads Tool is used to monitor and debug multi-threaded applications. To
display the Threads Tool, select Show Threads Tool from the Session Threads menu,
or Threads from the Session pop-up menu.

The above picture illustrates a situation using the lift.dws workspace after
executing the function RUN. The Pause on Error option was enabled and a Stop was
set on RUN[63]. When RUN suspended at this point, all other threads (1-8) were
automatically Paused. Note that all other threads happen to be Paused in the middle
of calls to system functions

The columns of the Threads Tool display the following information.

Column Description

Tid The Thread ID (⎕TID) and name (⎕TNAME) if set

Location The currently executing line of function code

State Indicates what the thread is doing. (see below)

Flags Normal or Paused.

Treq The Thread Requirements (⎕TREQ)
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Thread States
State Description

Pending Not yet running

Initializing Not yet running

Defined function Between lines of a defined function

Dfn Between lines of a dfn

Suspended Indicates that the thread is suspended and is able to accept
input from the Session window.

Session Indicates that Session window is connected to this thread.

(no stack)
Indicates that the thread has no SI stack and the Session is
connected to another thread. This state can only occur for
Thread 0.

Exiting About to be terminated

:Hold Waiting for a :Hold token

:EndHold Waiting for a :Hold token

⎕DL Executing ⎕DL

⎕DQ Executing ⎕DQ

⎕NA Waiting for a DLL (⎕NA) call to return.

⎕TGET Executing ⎕TGET, waiting for a token

⎕TGET
(Ready to continue) Executing ⎕TGET, having got a token

⎕TSYNC Waiting for another thread to terminate

Awaiting request Indicates a thread that is associated with a .NET system
thread, but is currently unused

Called .NET Waiting for a call to .NET to return.
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Paused/Normal
In addition to the thread state as described above, a thread may be Paused or Normal
as shown in the Flags column. A Paused thread is one that has temporarily been
removed from the list of threads that are being scheduled by the thread scheduler. A
Paused thread is effectively frozen.

Threads Tool Pop-Up Menu
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Switch to
Selecting this item causes APL to attempt to suspend (if
necessary) and switch to the selected thread, connecting it
to the Session and Debugger windows.

Interrupt
Causes a (STRONG) interrupt in the selected thread the
next time it is scheduled, essentially it allows you to
target an interrupt at a specific thread.

Ignore Interrupts Allows you to specify that the selected thread should
ignore weak interrupts.

Refresh Now Refreshes the Threads Tool display to show the current
position and state of each thread.

Auto Refresh
Selecting this item causes the Threads Tool to be updated
continuously, so that it shows the latest position and state
of each thread.

Pause Threads on
Error

If this item is checked, APL automatically Pauses all
other threads when a thread suspends due to an error or
an interrupt.

Paused
This item toggles a thread between being Paused and
Normal. It Pauses a Normal thread and resumes a Paused
thread.

Pause All This item causes all threads to be Paused.

Resume All This item resumes all threads.

Restart All This item resumes all Paused threads, restarts all
suspended threads, and closes the Debugger.
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Debugging Threads
The Debugger provides a tabbed interface that allows you to easily switch between
suspended threads for debugging purposes. To keep things simple for non-threaded
applications, Tabs are only displayed if there is a thread suspended that is other than
Thread 0. The following picture shows the Debugger open on a multi-threaded
application (LIFT.DWS) when only Thread 0 is suspended. This has been achieved
by setting a stop on RUN[63]
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In the next picture, the user has chosen to display the Threads Tool and then dock it
between the Session and Debugger windows. Note that only one thread, thread 0
(Run) is suspended. All the other threads are Paused (because Pause on Error is
enabled).
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The user then uses the context menu to Switch To Thread 14 (whose name is Lady
14) which was Paused on PERSON[7] in the middle of a ⎕TGET. The act of
switching to this thread caused it to be suspended at the beginning of its current line
PERSON[7] and the Debugger now displays two Tabs to represent the two
suspended threads. Note that both the thread id and the thread name are displayed on
the Tabs.

Note also that the Session window is connected to the thread indicated by the
selected Tab. In this case, typing MYFLOOR into the Session window displays the
value of the local variable MYFLOOR in Thread 14 (Lady 14).
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You can use the Tabs to switch between the suspended threads, so clicking the Tab
labelled 0:Run causes the display to change to the picture shown below. The
Session is now connected to Thread 0 (Run), so the value of ⎕LC is 63.
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The Event Viewer
The Event Viewer can be used to monitor events on Dyalog APL GUI objects. To
display the Event Viewer, select Event Viewer from the Session Tools menu.

You can choose:

l which types of events you want to monitor
l which objects you want to monitor

In the example illustrated above, the user has chosen to monitor events on a Form
#.f. Furthermore, the user has chosen to monitor GotFocus, LostFocus, MouseUp,
MouseDblClick and Configure events.

Entries in the Action column report the action that was associated with the event at
the time it was placed in the queue. This may or may not be the same as the action
that is associated with the event when it reaches the top of the event queue and is
processed.
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The Spy Menu

The Spy menu, illustrated above, provides the following options and actions.

Item Description

Clear Clears all of the event information that is currently
displayed in the Event Viewer.

Copy Copies the highlighted rows to the clipboard.

All
In this mode all the events are displayed in the Event
Viewer as they occur, whether or not there is an action
associated with them.

When Placed in
Object's Queue

In this mode only events that have associated actions
are displayed in the event viewer. Note that KeyPress
events are always queued and therefore always appear,
even if there is no associated action.

Current Queue State

In this mode the Event Viewer displays a snapshot of
the internal event queue. Only those events that are
currently in the internal APL event queue waiting to be
processed are displayed.

Enable Logging This item switches event logging on and off.

Close Closes the Event Viewer
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The Columns Menu

The Columns menu allows you to choose which information is displayed for the
events you are monitoring.



Chapter 1: The APL Environment 179

Item Description

ObjectName If checked, this item displays the name of the object on
which the event occurred.

ObjectType If checked, this item displays the type of the object on
which the event occurred.

Event Name If checked, this item displays the name of the event that
occurred.

Event Number If checked, this item displays the event number of the
event that occurred.

Parameters
If checked, this item displays the parameters for the
event that occurred. These are the items that would be
passed in the argument to a callback function.

Action

If checked, this item displays the action associated with
the event when the event is placed in the event queue,
for example the name of a callback function, or an
expression to be executed.

Thread ID If checked, this item displays the thread id of the thread
in which the event occurred

NQed
If checked, this item displays 0 or 1 according to
whether or not the event occurred naturally or was
generated programmatically by ⎕NQ.

Event ID If checked, this item displays the event id of the event
that occurred. This id is used internally.

TimeStamp If checked, this item displays the timestamp of the event
that occurred.
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The Select Menu

The Select menu allows you to highlight certain events in the Event Viewer. For
example, if you are monitoring TCP/IP events on a number of TCPSockets, you can
highlight just the events for a particular socket.

Item Description

Select All Highlights all the events.

Select Matching
Events

Highlights all the events that have the same Object and
Event Name (or Event Number) as the currently
selected event.

Select All Events on
This Object

Highlights all the events that have the same Object as
the currently selected event.

Select All Events of
this Type

Highlights all the events that have the same Event
Name (or Event Number) as the currently selected event

These items are also available from the pop-up menu that appears when you press the
right mouse button over an event displayed in the Event Viewer window.
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The Options Menu

The Options menu allows you to choose which information is displayed for the
events you are monitoring.

Item Description

Always on Top
If checked, this item causes the Event Viewer window
to be displayed above all other windows (including
other application windows).

Use APL font

If checked, this item causes the information displayed in
the Event Viewer window to be displayed using the
APL font (the same font as is used in the Session
window). If not, the system uses the appropriate
Windows font.

Settings... Displays the Event Viewer Options Dialog Box.
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Options Dialog Box
The Event Viewer Options dialog box allows you to select the objects and events that
you wish to monitor.

Events to view
The list box shows all the events that are support by the Dyalog APL GUI and allows
you to select which events are to be monitored. User defined events may be selected
by checking the User defined events box. Only those events that are selected will be
reported. You can sort the events by name or by event number by clicking the
appropriate column header.
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Objects to view
Item Description

Find Tool
Select from List

This tool allows you to choose a single specific Dyalog
APL GUI object that you want to monitor. To use it,
drag the Find Tool and move it over your Dyalog APL
GUI objects. As you drag it, the individual objects are
highlighted and their details displayed in the Name,
Type, Thread ID and Handle fields. Drop the Find Tool
on the object of your choice.

Clicking the Select from List button brings up a dialog
box that displays the entire Dyalog APL GUI structure
as a tree view. You can choose a single object by
selecting it.

Parent Object Enables event reporting on the selected object's
immediate parent.

Child Objects Enables event reporting on the all selected object's
descendants (at any level).

Same Thread Enables event reporting on all the objects in the same
thread as the selected object.

All Objects Enables event reporting on all Dyalog APL GUI
objects.

Objects of Type
Select from List

Activates the adjoining Select button and disables all
other Object selection mechanisms.

Clicking the Select from List button brings up a dialog
box that allows you to choose which types of Dyalog
APL GUI objects you want to monitor.
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The Session Object
Purpose: The Session object ⎕SE is a special system object that represents the

session window and acts as a parent for the session menus, tool bar
(s) and status bar.

Children Form, MenuBar, Menu, MsgBox, Font, FileBox, Printer, Bitmap,
Icon, Cursor, Clipboard, Locator, Timer, Metafile, ToolBar,
StatusBar, TipField, TabBar, ImageList, PropertySheet, OLEClient,
TCPSocket, CoolBar, ToolControl, BrowseBox

Properties Type, Caption, Posn, Size, File, Coord, State, Event, FontObj,
YRange, XRange, Data, TextSize, Handle, HintObj, TipObj, CurObj,
CurPos, CurSpace, Log, Input, Popup, RadiusMode, LogFile,
MethodList, ChildList, EventList, PropList

Methods ChooseFont, FileRead, FileWrite

Events Close, Create, FontOK, FontCancel, WorkspaceLoaded,
SessionPrint, SessionTrace

Description

There is one (and only one) object of type Session and it is called ⎕SE. You may use
⎕WG, ⎕WS and ⎕WN to perform operations on ⎕SE, but you cannot expunge it with
⎕EX nor can you recreate it using ⎕WC. You may however expunge all its children.
This will result in a bare session with no menu bar, tool bar or status bar.

⎕SE is loaded from a session file when APL starts. The name of the session file is
specified by the session_file parameter. If no session file is defined, ⎕SE will have
no children and the session will be devoid of menu bar, tool bar and status bar
components.

An additional feature is provided to establish code in the Session. See .

You may use all of the standard GUI system functions to build or configure the
components of the Session to your own requirements. You may also control the
Session by changing certain of its properties.

Note that the Session reports a Create event when APL is first started, and a
WorkspaceLoaded event when a workspace is loaded or on a clear ws.

The Session reports a SessionPrint event when certain types of output are about to be
displayed. This may be used to alter the normal default display. The Session also
reports a event when executing when an expression is execute with trace control.
This may be used to alter the normal default trace.
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Read-Only Properties
The following properties of ⎕SE are read-only and may not be set using ⎕WS:

Property Description

Type A character vector containing 'Session'

Caption A character vector containing the current caption in the title bar
of the Session window.

TextSize Reports the bounding rectangle for a text string. For a full
description, see TextSize in Object Reference.

CurObj
A character vector containing the name of the current object.
This is the name under or immediately to the left of the input
cursor.

CurPos

A 2-element integer vector containing the position of the input
cursor (row and column number) in the session log. This is ⎕IO
dependent. If ⎕IO is 1, and the cursor is positioned on the
character at the beginning of the first (top) line in the log,
CurPos is (1 1). If ⎕IO is 0, its value would be (0 0).

CurSpace

A character vector which identifies the namespace from which
the current expression was executed. If the system is not
executing code, CurSpace is the current space and is equivalent
to the result of ⊃''⎕NS''.

Handle The window handle of the Session window.

Log
A vector of character vectors containing the most recent set of
lines (input statements and results) that are recorded in the
session log. The first element contains the top line in the log.

Input
A vector of character vectors containing the most recent set of
input statements (lines that you have executed) contained in the
input history buffer.

LogFile The name of the session log file in use.

ChildList A vector of character vectors containing the types of object that
can be created as a child of ⎕SE.

MethodList A vector of character vectors containing the names of the
methods associated with ⎕SE.

EventList A vector of character vectors containing the names of the events
generated by ⎕SE

PropList A vector of character vectors containing the names of the
properties associated with ⎕SE.
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Read/Write Properties
The following properties of ⎕SE may be changed using ⎕WS:

Property Description

Caption A character vector containing the current caption in the title bar of
the Session window. See Session Caption on page 189.

Coord Specifies the co-ordinate system for the session window.

Data May be used to associate arbitrary data with the session object
⎕SE.

Event

You may use this property to attach an expression or callback
function to the Create event or to user-defined events. A callback
attached to the Create event can be used to initialise the Session
when APL starts.

File
The full pathname of the session file that is associated with the
current session. This is the file name used when you save or load
the session by invoking the FileRead or FileWrite method.

FontObj

Specifies the APL font. In general, the FontObj property may
specify a font in terms of its face name, size, and so forth or it may
specify the name of a Font object. For applications, the latter
method is recommended as it will result in better management of
font resources. However, in the case of the Session object, it is
recommended that the former method be used.

HintObj

Specifies the name of the object in which hints are displayed.
Unless you specify HintObj individually for session components,
this object will be used to display the hints associated with all of
the menu items, buttons, and so forth in the session. The object
named by this property is also used to display the message
"Ready..." when APL is waiting for input.

Popup
A character vector that specifies the name of a popup menu to be
displayed when you click the right mouse button in a Session
window.

Posn

A 2-element numeric vector containing the position of the top-left
corner of the session window relative to the top-left corner of the
screen. This is reported and set in units specified by the Coord
property.

Size A 2-element numeric vector containing the height and width of the
session window expressed in units specified by the Coord property.
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Property Description

State

An integer that specifies the window state (0=normal,
1=minimised, 2=maximised). You may wish to use this property to
minimise and later restore the session under program control. If
you save your session with State set to 2, your APL session will
start off maximised.

TipObj

Specifies the name of the object in which tips are displayed. Unless
you specify TipObj individually for session components, this object
will be used to display the tips associated with all of the menu
items, buttons, and so forth in the session.

XRange See Object Reference

YRange See Object Reference

Special Properties
The following properties of ⎕SE are used internally by Dyalog tools such as SALT.
They are not intended nor supported for general use and are not reported by PropList.

StatusWindow

This read-only property returns a reference to the Status
Window. The expression:
(⎕SE.⎕WG'StatusWindow')⎕WG'Text' returns the
(read-only) contents of the status window.

Editor
This read-only property returns a reference to the Editor
Window. The Editor generates the special events Fix,
AfterFix and Format.
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Special Events
The following special events are generated by ⎕SE or its child objects. They are used
internally by Dyalog tools such as SALT. They are not intended nor supported for
general use.

AfterFix
This event is reported by the Editor after it has
successfully fixed a new object, or a new version of an
object, in the workspace.

Fix This event is reported by the Editor when the user
attempts to fix an object.

Format This event is reported by the Editor when the user
attempts to format an object.

SessionPrint

This event is reported when a value is about to be
displayed in the Session window. The default display of
the value may be intercepted by a callback function and
displayed differently. This event is used by the ]box
and ]rows user commands.

SessionTrace

This event is reported when an expression is executed
with trace control. The trace behaviour may be
intercepted by a callback function and altered. This event
is used by the ]box and ]rows user commands.

WorkspaceLoaded This event is generated when a workspace is loaded or
upon )CLEAR.
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Session Caption
The Caption property of the Session may be set dynamically to a character vector
comprising free text and field names. Field names must be enclosed in braces and are
replaced in-situ by corresponding values.

Field Name Description

{TITLE} the window specific text

{WSID} ⎕WSID

{NSID} current namespace

{SNSID} short version of namespace (no #.)

{PRODUCT} for example, Dyalog APL/W

{VER_A} for example, 19

{VER_B} for example, 0

{VER_C} for example, 47586 (SVN revision)

{PID} process ID (decimal)

{CHARS} "Classic" or "Unicode"

{BITS} "32" or "64"

Table 21: Session Caption Fields

Example:

⎕SE.Caption←'Pete: {WSID} {Product} {VER_A}.{VER_B}'

The Session caption in a CLEAR WS will change to:

Pete: CLEAR WS Dyalog APL/W-64 19.0

Note that Caption returns the codified string used to set it.

⎕SE.Caption
Pete: {WSID} {Product} {VER_A}.{VER_B}
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AfterFix Event 822

Applies To: Editor  

Description

If enabled, this event is reported immediately after the Editor has successfully fixed a
new object, or a new version of an object, in the workspace.

You may not nullify or modify the event with a 0-returning callback, nor may you
generate the event using ⎕NQ, or call it as a method. However, returning 0 from a
callback will cause the Edit window to remain open if the user action was Fix and
Exit (EP).

The event message reported as the result of ⎕DQ, or supplied as the right argument to
your callback function, is a 7-element vector as follows :

[1] Object ref to the Editor object

[2] Event 'AfterFix' or 822

[3] Contents the contents of the Edit window, as a vector of character
vectors

[4] Space ref to the namespace in which the object will be fixed

[5] Old Name a character vector containing the original name of the
object when it was opened by the Editor

[6]
New
Name

a character vector containing the name of the object which
was fixed. This is empty if the object is a variable.

[7] File Name a character vector containing the name of the file (if any)
associated with the object.
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Fix Event 820

Applies To: Editor  

Description

If enabled, this event is reported when the user attempts to fix an object from the
Editor window. It is reported immediately, before the user's action is processed in
any way by the Editor.

The default action is to check whether the object has changed. If not, no further
action takes place. If the object has changed, the system validates the contents of the
Edit window, and either displays an error dialog or fixes a new version of the object
in the workspace. If the user action was to fix and exit (EP), the Edit window is
closed unless the validation failed.

If the callback function returns 0, the default action is aborted in its entirety (not even
the validation takes place) and the Edit window remains open.

You may not generate the event using ⎕NQ, or call it as a method.

The event message reported as the result of ⎕DQ, or supplied as the right argument to
your callback function, is a 7-element vector as follows :

[1] Object ref to the Editor object

[2] Event 'Fix' or 820

[3] Contents the contents of the Edit window, as a vector of character
vectors

[4] Space ref to the namespace in which the object will be fixed

[5] Old Name a character vector containing the original name of the
object when it was opened by the Editor

[6]
New
Name

a character vector containing the new name of the object.
This is empty if the object is a variable.

[7] File Name a character vector containing the name of the file (if any)
associated with the object.

For objects whose names are part of the content of the Edit window, this event is not
reported if the name is missing or invalid. Instead the system will display an error
dialog box.
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Format Event 821

Applies To: Editor  

Description

If enabled, this event is reported when the user attempts to format an object in the
Editor window.

If the callback function returns 0, the contents of the Edit window are not
reformatted.

You may not generate the event using ⎕NQ, or call it as a method.

The event message reported as the result of ⎕DQ, or supplied as the right argument to
your callback function, is a 6-element vector as follows :

[1] Object ref to the Editor object

[2] Event 'Format' or 821

[3] Contents the contents of the Edit window, as a vector of character
vectors

[4] Space ref to the namespace in which the object will be fixed

[5] Old Name a character vector containing the original name of the
object when it was opened by the Editor

[6]
New
Name

a character vector containing the new name of the object.
This is empty if the object is a variable.

SessionPrint Event 526

Applies To: Session  

Description

If enabled, this event is reported when a value is about to be displayed in the Session.
It is generated by the display of a variable or the result of a function including system
variables and functions. Error messages and output from system commands do not
generate this event.
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The event message reported as the result of ⎕DQ, or supplied as the right argument to
your callback function, is a 2-element vector as follows :

[1] Object ref or character vector

[2] Event 'SessionPrint' or 526

The attachment of a callback function intercepts and annuls the normal display of any
value.

Note that this event may be extended in future; in particular the number of elements
in the event message may be increased, and the event may be generated by some
system commands. You should therefore allow for such extensions in any code
which refers to SessionPrint.

When the event is generated, the left argument of the callback function contains the
value which was about to be displayed. The callback function may display this or any
other value, using default output or by assignment to ⎕. If so, this output will be
processed normally, without generating a subsequent SessionPrint event. If the
callback fails to explicitly display anything, nothing will appear in the Session.

Example

⎕VR'⎕SE.TimeStamp'
∇ VAL TimeStamp EV

[1] ⎕TS VAL
∇

'⎕SE'⎕WS'Event' 'SessionPrint' '⎕SE.TimeStamp'

2
2014 9 18 16 20 38 318 2

⎕A
2014 9 18 16 20 44 668 ABCDEFGHIJKLMNOPQRSTUVWXYZ

The result (if any) of the callback function is ignored.

You may not disable the event (by setting its action to ¯1), nor generate the event
using ⎕NQ, nor call it as a method.
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SessionTrace Event 527

Applies To: Session  

Description

If enabled, this event is reported when an expression is executed with trace control.
See Language Reference Guide: Set Trace. Error messages and output from system
commands do not generate this event.

The event message reported as the result of ⎕DQ, or supplied as the right argument to
your callback function, is a 4-element vector as follows :

[1] Object ref or character vector

[2] Event 'SessionTrace' or 527

[3] Function Character vector ('' if none)

[4] Line number Numeric scalar (0 if none)

The attachment of a callback function intercepts and annuls the normal display of
function name, line numbers and any value.

Note that this event may be extended in future; in particular the number of elements
in the event message may be increased. You should therefore allow for such
extensions in any code which refers to SessionTrace.

When the event is generated, the left argument of the callback function contains the
result value of the expression, if any. The callback function may display this or any
other value, using default output or by assignment to ⎕. If so, this output will be
processed normally, without generating any SessionTrace or SessionPrint events. If
the callback fails to explicitly display anything, nothing will appear in the Session.

If the expression has no value, then the callback function will be called monadically.
It is therefore required that the callback function is ambivalent (can be called both
monadically and dyadically).
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Example

)cs ⎕SE
⎕SE

∇ {VAL}TimeStamp EV
[1] ⍞←⎕TS(2↑2↓EV)
[2] :If 0≠⎕NC'VAL'
[3] ⍞←VAL
[4] :EndIf
[5] ⍞←⎕UCS 13

∇
)cs

#
'⎕SE'⎕WS'Event' 'SessionTrace' '⎕SE.TimeStamp'

∇ Foo
[1] ⍝ just a comment
[2] global←⎕A

∇

1 2 ⎕TRACE'Foo'
Foo

2020 7 3 14 2 37 762 Foo 1
2020 7 3 14 2 37 763 Foo 2 ABCDEFGHIJKLMNOPQRSTUVWXYZ

The result (if any) of the callback function is ignored.

You may not disable the event (by setting its action to ¯1), nor generate the event
using ⎕NQ, nor call it as a method.
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WorkspaceLoaded Event 525

Applies To: Session  

Description

If enabled, this event is reported when a workspace is loaded or on a clear ws.
You may not nullify or modify the event with a 0-returning callback, nor may you
generate the event using ⎕NQ, or call it as a method.

The event message reported as the result of ⎕DQ, or supplied as the right argument to
your callback function, is a 2-element vector as follows :

[1] Object ref or character vector

[2] Event 'WorkspaceLoaded' or 525

This event is fired immediately after a workspace has been loaded and before the
execution of ⎕LX.

The callback function you attach should be defined in ⎕SE.
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Configuring the Session
As supplied, your default session will have a menu bar, a tool bar and a status bar.
There are many ways in which you may configure this set-up, including the
following:

You may select a different APL font or character size.

You may alter the appearance of the menus by changing the Caption properties of the
various Menu and MenuItem objects. For example, you may prefer the menus to
appear in your own language.

You may alter the structure of the menus. For example, you may wish to create a
Search menu directly on the menu bar rather than having Find and Replace as part of
the Edit menu.

You may add new Menu and MenuItem objects to the menu bar, or new Button
objects to the tool bar, that execute APL functions or expressions for you. You can
store the code inside the ⎕SE namespace so that it is remains available when you
switch from one workspace to another.

You may add other objects to the tool bar to allow you to provide input for your
functions or to display output. For example, you may display a Combo object that
offers you a selection of names applicable to a particular task.

You may add additional toolbars.

You may remove objects too; for example, you can remove fields from the StatusBar
or even delete it entirely. Indeed, you may dispense with the menu bar and/or tool bar
as well.

This section illustrates how you can configure your session using worked examples.
The examples are by no means exhaustive, but are designed to demonstrate the
principles. Please note that the structure and names of the objects used in these
examples may not be identical to your default session as supplied. Before you
attempt to change your session, please check the structure and the object names using
⎕WN and ⎕WG. The supplied session was created using the function BUILD_
SESSION in the workspace BUILDSE. If you wish to make substantial changes to
your session, you may find it most convenient to edit the functions in this workspace,
re-run BUILD_SESSION, and then save it.

Please note that these examples assume that Expose Session Properties is enabled.
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Changing the Font
The APL session font is defined by the Font property of ⎕SE. To change the font
permanently, you should select a different Font and/or size of Font using the combo
and spinner boxes on the Session toolbar, and save your Session.

Classic Edition is distributed with bitmap fonts suitable for use on your screen, and
TrueType fonts for your printer. You can use the TrueType font on the screen, but it
is less attractive than the bitmap fonts at low resolutions. The bitmap fonts come in
two sizes (16 x 8 and 22 x 11) and two weights (normal and bold). You may select
other sizes, so long as the height is a multiple of 16 or 22. The scaling is performed
automatically by Windows.

Changing Menu Appearance
The name of the Session MenuBar is '⎕SE.mb'. To simplify the specification of
object names, we will first change space to the MenuBar itself:

)CS ⎕SE.mb
⎕SE.mb

The names of the Menu objects owned by the MenuBar are given by the expression:

'Menu' ⎕WN ''
file  edit  view  windows  session  log  action  options 
tools  threads help

The current caption on the file menu is:

file.Caption
&File

To change the Caption to Workspace:

file.Caption←'Workspace'

To change the colour of the New option in the File menu to red:

file.clear.FCol←255 0 0
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Reorganising the Menu Structure
This example shows how you may alter the structure of the session menus by adding
a Search menu to the menu bar to provide access to the Find and Find/Replace
dialog boxes and removing these options from the Edit menu.

To simplify the process, we will first change space into the MenuBar object itself:

)CS ⎕SE.mb
⎕SE.mb

Then we can begin by adding the Search menu. You can specify where the new
menu is to be added using its Posn property. In this case, Search will be added at
position 3 (after Edit).

'search'⎕WC 'Menu' '&Search' 3

Next we will remove the Find and Replace MenuItem objects from the Edit menu.
Their names can be obtained from ⎕WN:

'MenuItem'⎕WN'edit'
edit.prev  edit.next  edit.clear  edit.copy  edit.paste 
edit.find  edit.replace

It is worth noting that these MenuItems perform their actions because their Event
property is set to execute the system operations [Find] and [Replace]
respectively when they are selected.

edit.find.Event
Select  [Find] 

edit.replace.Event
Select  [Replace]

The following statement removes them from the Edit menu:

⎕EX¨'edit.find' 'edit.replace'

and the following statements add them to the Search menu:

'search.find' ⎕WC 'MenuItem' '&Find'
('Event' 'Select' '[Find]')

'search.replace' ⎕WC 'MenuItem' '&Replace'
('Event' 'Select' '[Replace]')
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Adding your own MenuItem
This example shows how you can add a menu item that executes an APL expression.
In this case we will do something very simple; namely add a Time option to the
Tools menu which will execute ⎕TS. Notice that the statement also defines a Hint.
This will be displayed when you select the option, prior to releasing the mouse
button to action it.

Once again, we will start by changing space into the Tools menu itself

)CS ⎕SE.mb.tools
⎕SE.mb.tools

Then we will define a new MenuItem to perform the action we require:

'ts'⎕WC'MenuItem' '&Time'
('Event' 'Select' '⍎⎕TS')
('Hint' 'Display Timestamp')

The ⍎ symbol is very important and distinguishes an expression to be executed
immediately, as in this case, from a callback function. The resulting Tools menu now
appears as follows:

A customised Tools menu

Selecting Time produces the following output in the session:

2007 12 10 17 10 2 0
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Adding your own Tool Button
This example shows how you can add a button to the session tool bar that executes
an APL function called XREF.

XREF analyses the function whose name is under the cursor, listing the names of the
other functions that it calls in a Form.

∇ XREF;REFS;FN
[1] :If 0<⍴FN←'⎕SE'⎕WG'CurObj'
[2] :AndIf 3=⎕NC FN
[3] REFS←⎕REFS('⎕SE'⎕WG'CurSpace'),'.',FN
[4] REFS←(↓REFS)~¨' '
[5] REFS←(3.1=⎕NC REFS)/REFS
[6] REFS←REFS~⊂FN
[7] :If 0<⍴REFS
[8] 'F'⎕WC'Form'('Functions called by ',FN)
[9] F.FontObj←⎕SE.FontObj
[10] 'F.L'⎕WC'List'REFS(0 0)(100 100)
[11] :EndIf
[12] :EndIf

∇

XREF[1] gets the value of the CurObj property of ⎕SE which reports the name
under the cursor.

XREF[3] prefixes this name by its pathname which comes from the CurSpace
property which reports the user's current namespace.

To make this function available from a Session tool button, we need to do a number
of things. Firstly, we must install the function in ⎕SE so that it is always there,
regardless of the current active workspace. This is easily achieved using the Explorer
or ⎕NS.

'⎕SE' ⎕NS 'XREF'

Next we will add a new button to the tool bar in the Tools CoolBand. Ideally we
would use a suitable bitmap, but to simplify the example, we will use a standard text
button:

)CS ⎕SE.cbtop.bandtb3.tb
⎕SE.cbtop.bandtb3.tb

'xref' ⎕WC 'Button' 'XREF'
'xref' ⎕WS 'Event' 'Select' '⍎⎕SE.XREF'

Adding a tool button

All that remains is to save the new Session.
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Session Initialisation
Introduction
Each time Dyalog starts it loads and loads an initialisation file whose name is defined
by the DyalogStartup parameter. The code defined in this file performs Session
initialisation. If DyalogStartup is undefined, the system uses the first file it finds
named StartupSession with file extension .aplf, .apln or .aplc in the
Dyalog directory. If the file has the .aplf extension, it is executed. If it has a
.apln or .aplc extension, the system instantiates the namespace or class and
executes its Run function (if it exists).

At the end of the initialisation, the function defined by the .aplf file (or the Run
function of the namespace or class) becomes the niladic function
⎕SE.StartupSession, which be called to re-run the session initialisation
procedures.

Implementation
Code to be installed in ⎕SE is specified in APL source code files contained in
Session initialisation directories identified by the DyalogStartupSE parameter. If
this parameter is not specified, the default is a directory named StartupSession
located in three standard locations as described below. See Interface Guide:
DyalogStartupSE.

Only content stored in files matching the wildcard patterns *.dyalog and *.apl?
will be loaded. All such files must be appropriate for ⎕FIX.

For each sub-directory in a Session initialisation directory, a corresponding
namespace is created in ⎕SE. Any source code files in these sub-directories will be
fixed in their respective corresponding namespaces, and nested sub-directories
become nested namespaces, recursively

Every top-level directory that is loaded as a namespace in ⎕SE can have a Run
function which (depending on the value of the DyalogStartup_X parameter, will be
called after everything has been loaded. This does not apply to sub-namespaces. See
DyalogStartup_X on page 1.

This requires Link which is available by default. A custom version of Link can be
used. See DyalogLink on page 1.

The Session initialisation directories are processed in alphabetical order and code
defined in each directory will replace code with the same name defined previously. In
effect, this means that user-supplied content can replace content supplied by Dyalog
Ltd. and version-specific content can replace version-agnostic content.

../../../../../Content/UserGuide/Installation and Configuration/Configuration Parameters/DyalogStartup_X.htm#DyalogStartup_X
../../../../../Content/UserGuide/Installation and Configuration/Configuration Parameters/DyalogLink.htm#DyalogLink
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Default Session Initialisation Directories
If the DyalogStartupSE parameter is undefined, APL looks for Session initialisation
directories named StartupSession in the following three locations, and
processes them in that order:

1. The Dyalog installation directory (which contains the dyalog executable)
2. A version-agnostic sub-directory in the user directory (the standard directory

for user-related Dyalog APL files)
3. A version-specific sub-directory in the user directory, whose name is derived

as described below.

Under Windows these might be:

1. C:\Program Files\Dyalog\Dyalog APL-64 19.0 Unicode
2. C:\Users\Pete\Documents\Dyalog APL Files
3. C:\Users\Pete\Documents\Dyalog APL-64 19.0 Unicode

Files

The version-specific name is :

Dyalog APL{bit} {version} {edition}

where:

l {bit} is "-64" if 64-bit version, otherwise nothing
l {version} is the main and secondary version numbers of dyalog.exe separated
by ".".

l {edition} is "Unicode" for the Unicode Edition, otherwise nothing
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User Commands
Dyalog includes a mechanism to define User Commands.

User commands are developer tools, written in APL, which can be executed without
having to explicitly copy code into your workspace and/or save it in every workspace
in which you want to use it.

A User Command is a name prefixed by a closing square bracket, which may be
niladic or take an argument. A User Command executes APL code that is typically
stored somewhere outside the current active workspace.

By default, the existing SPICE command processor is hooked up to the user
command mechanism, and a number of new SPICE commands have been added. For
example:

]display 'hello' (⍪'world')
┌→────────────┐
│ ┌→────┐ ┌→┐ │
│ │hello│ ↓w│ │
│ └─────┘ │o│ │
│ │r│ │
│ │l│ │
│ │d│ │
│ │w│ │
│ └─┘ │
└∊────────────┘

The implementation of User Commands is very simple: If a line of input begins with
a closing square bracket (]), and there exists a function by the name ⎕SE.UCMD,
then the interpreter will call that function, passing the input line (without the bracket)
as the right argument.

To add a user command, drop a new Spice command file in the folder SALT\Spice.
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File Explorer Integration

File Associations
During installation, Dyalog establishes the following file associations:

Type File Extension Application

Shell Scripts .apls
Dyalog script execution
engine via Windows Power
Shell

Sources .aplc, .aplf, .apli,
.apln, .aplo, .dyalog Dyalog Editor

Configuration .dcfg Dyalog Editor

SALT apps .dyapp Dyalog

Workspaces .dws Dyalog

When you double-click on a file with one of the above extensions, the file is opened
with the corresponding application.

In addition, two items are added to the Windows Explorer context menu for
directories, namely Load with Dyalog and Run with Dyalog. Both these items start
Dyalog and attempt to import code from the corresponding directory using Link. The
Run with Dyalog option also calls the function named Run if it exists. See Load
Parameter on page 1.

For more information about Link, see https://dyalog.github.io/link/3.0/.

The ]fileAssociations user command may be employed to alter these settings.
For details, enter:

]fileassociations -?

Browsing Workspaces and Source Files
(Unicode Edition Only)
You can browse the contents of workspaces and Dyalog source files using the
preview pane of Windows File Explorer. The following example show what you see
in the preview pane when you select the supplied workspace ddb.dws.

../../../../../Content/UserGuide/Installation and Configuration/Configuration Parameters/Load.htm#Load_Parameter
../../../../../Content/UserGuide/Installation and Configuration/Configuration Parameters/Load.htm#Load_Parameter
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When you move the cursor to the next workspace in the list, dfns.dws, the preview
pane is immediately updated to show its contents.
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If you open the Fns/Ops node and click on a function name, the function is displayed.
The next picture shows the function assign.
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You can also browse Dyalog source files. The following picture shows what you see
when you select the fileUtils.dyalog file.

Note that you may only view workspace objects and scripts in the preview pane, it is
not possible to edit them in the preview pane.
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Editing Dyalog Source Files
You may edit a source file from File Explorer by first selecting the source file and
then choosing Edit from the File Explorer context menu.

This brings up the standard Dyalog Editor, in a stand-alone window, just as it would
appear if undocked from the Session, as shown in the next picture.
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Index

.

.NET Classes
exploring 96

A

ActiveXControl object 68
aedit User Command 39
AfterFix 190
aligning comments 135
APL fonts 198
Array Editor 39, 63
assemblies

exploring 96
auto_pw parameter 33
AutoComplete 32

B

backtick keyboard 11
Browse .NET Assembly dialog box 97

C

chart wizard 63
class constructor 100
Classes

browsing 79
Classic Dyalog mode 158

multiple trace windows 166
single trace window 167

Classic Edition 47, 66
ClassicMode parameter 118
ClassicModeSavePosition parameter 118
CloseAll system operation 48
collapsing outlines 132, 137, 143
compiler errors 131

configuring the session 197
Constructors folder 100
context menu 28
Create (session event) 184
CurObj (session property) 5, 185
CurPos (session property) 185
Current Object 5
CurSpace (session property) 185

D

Debugging Threads 172
default_wx parameter 53
deleting lines 31
Docking 23
Dyalog_LineEditor_Mode 8
DyalogStartSE Parameter 202-203
DyalogStartup Parameter 202

E

edit_cols parameter 115, 118
edit_first_x parameter 115, 118
edit_first_y parameter 115, 118
edit_offset_x parameter 115, 118
edit_offset_y parameter 115, 118
edit_rows parameter 115, 118
editor

aligning comments 135
class treeview 131, 144
collapsing outlines 132
compiler errors 131
edit menu 126
editing classes 142
expanding outlines 132
file menu 122
function line numbers 131
invoking 113
outlining 132, 137
refactor menu 130
sections 145
selecting text 119
syntax menu 128
toolbar 120
trace, stop and monitor 136
using 133
view menu 131
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windows menu 129
endsection statement 139, 145
Enums 95
Event (session property) 186
Event Sets 94
Events

AfterFix 190
Fix 191
Format 192
SessionPrint 192
SessionTrace 194
WorkspaceLoaded 196

executing expressions 32
execution (tracing) 164
expanding outlines 132, 137, 143

F

File (session property) 186
file associations 205
file explorer integration 205
find 148
find and replace dialogs 148
Find Objects Tool 105
Fix 191
Font (session property) 186
Format 192
function line numbers 131-132

H

Handle (session property) 185
HintObj (session property) 186

I

ILDASM 96
IME Configuration 10
Input (session property) 185
input codes 15
input line 31
interrupt 6

K

keyboard shortcuts 2, 13

L

language bar 29
line numbers 131-133
Log (session property) 185
LogFile (session property) 185

M

Metadata 96, 98
Methods folder 103
monitor 136
mouse

using in session 5
multiline input 8

N

NET classes 96
Net Metadata 85
New method 100

O

Object CoClasses 89
Object Properties

COM Properties tab 111
Monitor tab 110
Net Properties tab 112
Properties tab 108
Value tab 109

Objects 91
OLEClient object 85, 88
OLEServer object 68
outlining 132, 137

P

page width 33
Popup (session property) 186
Posn (session property) 186
private 100
Properties folder 101
PropertyExposeRoot parameter 53
PropertyExposeSE parameter 53
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R

registry keyboard 3
replace 148

S

section statement 139, 145
selecting text 119
session

configuring 4, 197
deleting lines 31
file menu 43
help menu 55
initialisation 202
options menu 52
popup menu 57
session menu 49
status bar 66
status field styles 66
threads menu 54
tools menu 53
value tips 35

session action menu 50
session colour scheme 19
session ghutter 7
session initalisation 202
session log 21, 31
session log menu 50
session menubar 43

action menu 50
edit menu 46
file Menu 43
help menu 55
log menu 50
options menu 52
session menu 49
threads menu 54
tools menu 53
view menu 48
windows menu 48

session object 4, 22, 49, 184
session statusfields 67
session toolbars 61

edit tools 64
object tools 63

session tools 65
tools tools 64
workspace tools 62

session_file parameter 4, 22, 184
SessionOnTop parameter 118
SessionPrint 184, 192
SessionTrace 194
Show trace stack on error 157
Size (session property) 186
source as typed 155
SPICE 204
StartupSession 202
State (session property) 187
Status window 23, 68
stop 136
system operations 4, 49, 199

T

Threads Tool 168
TipObj (session property) 187
trace 136
trace tools 159
Trace_on_error parameter 157
tracer

automatic trace 157
break-points 165
Classic Dyalog mode 158
controlling execution 164
invoking 157
naked trace 157
tracing an expression 157

treeview 131, 144
Type Libraries 76, 85

U

underscored characters 13
Unicode Edition 66
User Commands 204

aedit 39

V

value tips 35
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view menu
editor 131
session) 48

Visual Styles 61

W

white space 136
WorkspaceLoaded 184, 196
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